DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: recover System tablespace from RMAN?

  1. #1
    Join Date
    Dec 2000


    Is it possible to restore and recover the System tablespace using RMAN? I can't seem to allocate a channel in RMAN with the target database closed, and yet I know I cannot take the System ts offline in order to perform recovery.
    If I have to manually restore the System ts, then how do I do that if all I have is one big backuppiece for the entire database? (Online complete backups are taken daily.)

    Please help.


  2. #2
    Join Date
    Apr 2001
    I have not done that before but I think target database should be in mount state if you want to do a cold backup or restore system tablespace. RMAN should be able to read the control file of the target database.

  3. #3
    Join Date
    Dec 2000
    I tried recovery while db is in mount. This is the error stack I get:

    Recovery Manager: Release - Production

    RMAN-06005: connected to target database: NEWTEST (DBID=1697269960)
    RMAN-06008: connected to recovery catalog database

    RMAN> run {
    2> allocate channel ch1 type disk format 'd:\ora8i\database\newtest\b_%u_%s_%p';
    3> restore ( tablespace 'SYSTEM' );
    4> recover tablespace 'SYSTEM' ;
    6> }
    RMAN-03022: compiling command: allocate
    RMAN-03023: executing command: allocate
    RMAN-08030: allocated channel: ch1
    RMAN-08500: channel ch1: sid=11 devtype=DISK

    RMAN-03022: compiling command: restore
    RMAN-03026: error recovery releasing channel resources
    RMAN-08031: released channel: ch1
    RMAN-00571: ===========================================================
    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
    RMAN-00571: ===========================================================
    RMAN-03002: failure during compilation of command
    RMAN-03013: command type: restore
    RMAN-03014: implicit resync of recovery catalog failed
    RMAN-06004: ORACLE error from recovery catalog database: RMAN-20003: target database incarnation not found in recovery catalog

    Recovery Manager complete.
    child process exited abnormally

    Any other ideas?

  4. #4
    Join Date
    Mar 2000

    RMAN Recovery

    Hi, 24th April 2001 19:58 hrs chennai

    I found this from one of the web sites how to recover system TS from RMAN.

    I am sure this will help you to tide over from your problem.

    If your succesful let me also know the steps.
    else please let me know to extend my help once again.



    Attitude:Attack every problem with enthusiasam ...as if your survival depends upon it

  5. #5
    Join Date
    Dec 2000
    I think that my backups must have been corrupted. I deleted all old backups and took a new one. Then I tried it and it worked with the db in "mount". Thanks for the link - that is a great example. How did you find that? Are there any more examples?

    I'm trying to test all likely scenarios on our db before we go live...

  6. #6
    Join Date
    Nov 2000
    what if, using rman nocatalog (use control file) to recover system tablespace. I guess it can not do it - here is my thought

    rman to restore datafile need db mount
    no system tbs, how you mount db?

    any one agree?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width