DBAsupport.com Forums - Powered by vBulletin
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: 12c Grid Agent installation issues - Shell path is incorrect or not defined

  1. #11
    Join Date
    Apr 2011
    Largo, FL.
    Quote Originally Posted by AbuYazan View Post
    Dear Mr. DMK
    thanks a lot for your explanation ,
    I installed oem13 on window server 2016 and when i tried to deploy agent on another windows server i get this error Shell path is incorrect or not defined .
    I installed cygwin on c:/cygwin and the file ssPaths_msplats.properties exists, and in it the variable SH_PATH is defined as c:/cygwin/bin/sh.exe.
    then I created a user named cyg_server, who is in the Remote Desktop, Administrators and ora_dba groups .
    and I recreated the password for the cyg_server user in /etc/passwd
    but after that i get the same error ,
    please advice me ,
    thanks in advance ,
    Best Regards ,
    Did you notice that his DMK's post was made NINE YEARS ago?

  2. #12
    Join Date
    Sep 2023
    It seems like you're encountering an issue while deploying the Oracle Grid Control agent on a UNIX (AIX) server, specifically related to the shell path. Let's address this problem:

    Check Agent Deployment Directory:

    Ensure that the directory where you are deploying the agent exists and is accessible on the target server. If it doesn't exist, you may need to create it manually.
    Verify Oracle Inventory Directory:

    Confirm the Oracle Inventory directory on the target server. This directory typically contains information about Oracle software installations. It's possible that the Oracle Inventory directory is located in /u01/app/oracle on your AIX server.
    Check Shell Path Configuration:

    Review the ssPaths_aix.properties file carefully. Verify that the SH_PATH parameter is set to the correct path for the AIX shell. On AIX systems, the default shell is usually located at /usr/bin/ksh. Try setting SH_PATH to /usr/bin/ksh and see if that resolves the issue.
    SSH Configuration:

    Ensure that SSH is properly configured on both the Enterprise Manager server and the AIX target server. SSH is often used for communication during agent deployment. Verify that SSH keys, if used for authentication, are correctly set up.
    Check SSH Path:

    Confirm the path to the SSH executable on the target server. You mentioned that /usr/bin/ssh is the path, which is correct. Ensure that SSH is working correctly by running simple SSH commands between the Enterprise Manager server and the target server.
    Oracle Support:

    If the issue persists, it might be beneficial to reach out to Oracle Support for assistance. They can provide guidance specific to your environment and Oracle Grid Control version.
    Remember that Oracle Grid Control agent deployment can be sensitive to configuration details, so double-checking paths, permissions, and network connectivity is crucial. Also, ensure that you have the necessary privileges and permissions to deploy agents on the target server.

    Lastly, consider referring to Oracle's official documentation and any specific documentation related to your Oracle Grid Control version for additional troubleshooting steps and best practices.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width