DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: PL/SQL Package Error Related to Oracle Version?

  1. #1
    Join Date
    Apr 2007
    Posts
    20

    PL/SQL Package Error Related to Oracle Version?

    We are newly upgraded to Oracle 10.2.0.4. We have a package that will not compile yet the vendor claims no changes were made and it could be the version of Oracle we are running. This is the portion of the statement, and the error it produces (I am running this in TOAD).

    OPEN o_RC1 FOR
    WITH
    column_list AS
    (SELECT DISTINCT....

    Error: ERROR line 203, col 13, ending_line 203, ending_col 23, Found 'column_list', Expecting: @ string or ( or % . [ or (+) AT DAY YEAR or ** MULTISET or * / MOD REM or + - || or ; USING

    I'm just curious if anyone knows if this is infact an issue with our version of Oracle and syntax adjustments need to be made. I cannot seem to find anything on Google.

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,334
    run it in sqlplus and get the proper error

  3. #3
    Join Date
    Apr 2007
    Posts
    20
    Ran it in SQL Plus.

    Warning: Package Body created with compilation errors.

  4. #4
    Join Date
    Apr 2007
    Posts
    20
    the vendor found the error finally. thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width