DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: Datapump - using a mapped network drive

Hybrid View

  1. #1
    Join Date
    Apr 2007

    Datapump - using a mapped network drive

    I tried to initiate a datapump export from a 10g database but I would like the export dump to be copied via a mapped network drive to another server.

    These are the steps I used:

    1. I created a directory object on the source database :

    create directory DP_TEST_DIR AS '\\uknbumed02\T$\dp_pump_test';

    2. grant, read ON DIRECTORY DP_TEST_DIR to system;

    3. I run the export using the EM console

    I get this error:

    Errors: ORA-39002: invalid operation ORA-39070: Unable to open the log file. ORA-29283: invalid file operation ORA-06512: at "SYS.UTL_FILE", line 475 ORA-29283: invalid file operation Exception : ORA-39002: invalid operation ORA-06512: at "SYS.DBMS_SYS_ERROR", line 79 ORA-06512: at "SYS.DBMS_DATAPUMP", line 2926 ORA-06512: at "SYS.DBMS_DATAPUMP", line 3162 ORA-06512: at line 2

    There is a metalink note 428130.1 which suggests changING the Oracle service to run as this account. Is there another workaround for this problem?


  2. #2
    Join Date
    Apr 2007
    Hi everyone

    Has anyone used datapump with a mapped network drive successfully?


  3. #3
    Join Date
    Mar 2008
    If i understand your requirement correctly you want to import the data from one db to another db using network link. If so this is what you need to do

    From target db,
    create a db link to source db. To any schema which has got proper privs.

    impdp \"/ as sysdba\" directory=IMPDP_DIR NETWORK_LINK= SCHEMAS=SCOTT LOGFILE=SCOTT.log

    Satheesh Babu S

  4. #4
    Join Date
    Apr 2007
    Hi Satheesh

    No I don't want to use a network link. I would like the export dumped across to another server using a mapped network drive.

    Hope this is clear.

    Thanks for your help.

  5. #5
    Join Date
    Sep 2002
    Note 428130.1 tells you what to do - so whats the problem in doing it?

  6. #6
    Join Date
    Apr 2007
    The note involves shutting down the database and changing the Instance service to run as the OS account. I do not want to do this and was wondering if there was another way short of shutting down the database.

    Never mind if this is the only workaround.

    Thank you for your time.

  7. #7
    Join Date
    Aug 2023
    This is a bug so use the below parameter and restart the DB and try expdp

    ALTER SYSTEM SET "_disable_directory_link_check" = TRUE SCOPE=both;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width