DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: TNSNAMES.ORA Error

  1. #1
    Join Date
    Nov 2002


    I am experiencing problems using Oracle 9.2 with a Win2K
    machine with SP3. I cannot connect to a database with SQL
    Plus. I receive the following error: 'ORA-12535 TNS:
    operation timed out'. I have verified I have the same
    TNSNAMES.ora file as my coworker does and it resides in the
    correct directory (...\network\admin\). He can connect to
    the database but does not have SP3 installed. I tried
    another Win2K machine of mine which had SP3 and I receive
    the same error.

    As a side note, I also receive the same error if I use
    Oracle Enterprise Manager.

    Rumor has it the issue deals with SP3. Any thoughts?

    I am unable to uninstall SP3 since my Win2K build had SP3
    integrated with it. So, I am looking for a solution that
    does not require me to wipe my machine clean and install
    Win2K w/o SP3.

    Thanks in advance...

  2. #2
    Join Date
    May 2002
    The TNS-12535 or ORA-12535 error is normally a timeout error associated with Firewalls or slow Networks. It can also be an incorrect listener.ora parameter setting for the CONNECT_TIMEOUT_ value specified. In essence, the ORA-12535/TNS-12535 is a timing issue between the client and server.

    Error: ORA-12535 / TNS-12535 Text:
    TNS: operation timed out
    Cause: The requested connection could not be completed within the timeout period specified by the CONNECT_TIMEOUT parameter in listener.ora. This error arises from the tnslsnr.

    Action: Either reconfigure CONNECT_TIMEOUT to be 0, which means wait indefinitely, or reconfigure CONNECT_TIMEOUT to be some higher value. Or, if the timeout is unacceptably long, turn on tracing for further information.

  3. #3
    Join Date
    Nov 2002
    The DBA verified the CONNECTION_TIMEOUT setting is set correctly. FYI: there are 50+ users connecting. I seem to be one of the few experiencing problems.

    What is unusual is the coworker who can connect is even sharing the same cable modem connection as me (through the router). Both of my machines cannot connect with Win2K SP3. His machine is also Win2K but with SP1. All machines have Oracle 9.2 client.

    Thanks for the response, Steven!

  4. #4
    Join Date
    Jan 2002
    Show us your tnsnames file?

  5. #5
    Join Date
    Mar 2001
    looks like a bug on the service pack. It seems to change the permissions on the machine. At least that is what seems to be happening to those unlucky few who have installed on their SERVERS - Oracle won't start for them or the software will not install on a win2k machine with sp3:


    I have sp2 on my client with no problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width