DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Peculiar Export Error

  1. #1
    Join Date
    Oct 2001


    I am shifting my database which is currently running on windows NT server 4.0 to another machine with the same OS but a better configuration(more RAM and higher CPU speed).

    (My current and new Oracle version are the same and i am using the same CD to do the installation)

    While installing database(Oracle8i version 8.1.5) on my new server i chose custom installation and did not opt for creating a database while the installation process. After the installation was over i created a database using the DBA assistant , keeping the location of control files , redo logs and database files the same as my current installation. Then i took full database export from my current installation and imported the dump into the new database. The export and import both completed successfully.

    After that i copied the init.ora file of the current installation to the new installation and restarted the database from services option in the NT Control Panel.

    The service started successfully but when i tried to connect to oracle through SQL*PLUS i was not able to connect and it gave an error "Shutdown or initialization in progress".
    By trial and error i tried to change the parameters in the init.ora of the new installation and when i changed the "compatible" parameter to "8.1.0" the database started successfully.

    Now my problem is that when i am trying to take an full database export of new database i am getting the following error:

    EXP-00008: ORACLE error 904 encountered
    ORA-00904: invalid column name
    EXP-00000: Export terminated unsuccessfully

    I have run catexp.sql,catproc.sql and catalog.sql but i am still getting the error.
    I am able to take export from exp80.exe(Oracle 8.0.4) but i am not able to take export using exp.exe(Oracle8i 8.1.5)
    please advise. Any help will be welcome. Thanx in advance.

  2. #2
    Join Date
    Oct 2000
    Saskatoon, SK, Canada
    After the export and import, did you run the catproc and catlog scripts? Did you check your tnsnames.ora and listener.ora files configured properly?


    Life is a journey, not a destination!

  3. #3
    Join Date
    Sep 2001
    Fort Smith
    u installed 8.1.5.
    created new database.
    imported the data exported from current database.
    when trying export on new it is failing...
    is it so.. i am bit confused..

    and u say that exp80 is doing the export where from you got that on 8.1.5 new database?

    another Q is u are able to use connect string to get into database from sql plus and as also export utility?

    I think there is some compatibility problem.
    try to re run all the scripts catalog, catproc,catexp etc.,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width