lost system datafile
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: lost system datafile

  1. #1
    Join Date
    Feb 2001
    Posts
    203
    Hi Folks,
    One of our dba is not there and his group lost disk on NT box. NT admin rebuild that disk and asked me to restore the files from backup. So i went there and noticed that system datafile are misssing. I went to backup tool and copied from their. Then i followed these steps.

    DOS PROMPT
    ---------------

    1.FIRST I CHECKED THE ENV BY ISSUING THE COMMAND

    c:\oracle\ora8i>set

    2. I noticed that ORACLE_HOME IS THERE BUT ORALCE_SID IS NOT THERE IN THE ENV. SO

    c:\oracle\ora8i>set ORACLE_SID=SIDNAME

    3. Again i checked the env and now sid name is there in env. Then i connect to the svrmgrl.

    c:\oracle\ora8i>svrmgrl

    svrmgr>connect internal

    At this stage it's asked me the password, I don't know the internal password but i know the sys password. So i gave the that password. It's connected. Then

    svrmgr>startup mount
    ora 01031 insufficient privileges;

    So i exit from svrmgrl and connected to sqlplus

    c:\oracle\ora8i>sqlplus

    username: internal as sysdba
    ora 01031 insufficient privileges;

    I am new to NT, So if anybody will give some idea it will help me.


    sree

  2. #2
    Join Date
    Aug 2000
    Posts
    462
    you can connect like:

    connect sys/pwd as sysdba

    You don't have to use internal.

    Then:

    startup mount


  3. #3
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    If you could not connect as internal chnaces are you won't be able to connect as sysdba.

    Try this --

    1. Make sure that the NT user is part of the ORA_DBA group in the NT User Administraion; If not then add this user to that group.

    2. Go to the ora_home\network\admin\sqlnet.ora file and add the following entry --

    sqlnet.authentication_services=(NTS)

    After this point start a DOS prompt and --

    set oracle_sid = yoursidname

    SVRMGRL

    connect internal

    You should be able to connect at this point.

    Let me know if you still have problem and we will see if we need to recreate the Pasword file.

    - Rajeev

    Rajeev Suri

  4. #4
    Join Date
    Feb 2001
    Posts
    203
    I connect like connect sys/password as sysdba

    and i issued
    svrmgr>shutdown abort
    instance shutdown

    svrmgr>startup mount
    ora 01031 insufficient privileges;

    I checked in the services and i find that oracleservicesidname service is started and. Really i am not understanding how to check the process on the NT.
    One more thing. I am connecting as one user. So is that user has to get some admin privileges ? If yes then How can i check the user privileges?
    sree

  5. #5
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    After you do "Shutdown abort" and before you do "startup mount" issue the "connect sys/password as sysdba" one more time. There is a possibility you are losing the privilege after the Abort.

    To see if you are a member of ORA_DBA group on NT go to --

    Start - Programs - Administrative Tools - User Manager for Domains

    Find your username and see what Groups are assigned to him.
    The GUI is very straight forward but if you don't have much experience you may need help from your NT admin.

    - Rajeev


    Rajeev Suri

  6. #6
    Join Date
    Feb 2001
    Posts
    203
    Hi Suri,
    All ready this line is there in sqlnet.ora
    sqlnet.authentication_services=(NTS) .

    All ready i tried to open
    Start - Programs - Administrative Tools - User Manager for Domains

    but the user manager for domains is not there under administrative tools.

    Give me some more places to check. One more thing.

    In services ORACLESERVICESSIDNAME IS STARTED. So my question is how we check the process in nt. Thanks.
    sree

  7. #7
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    What version of NT are you using?

    The OracleServiceSIDName is a service that runs on behalf of Oracle. This must be running in order to start the database instance.

    You can start the database with the Service. For this you need to change a setting in the NT Registry

    It's at --

    HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME0\ORA_SID_AUTOSTART

    On your machine HOME0 could be someting else as would be the SID name

    When this flag is set to TRUE the database will start with the Service.
    However, in you case it will not start because the system datafile is missing.

    It's erroring out when trying to open the database.

    You can see this in the Alert Log at --

    c:\oracle\ora81\admin\sid_name\bdump\sid_alrt.ora file

    Did you try "connect sys/password as sysdba" and then startup mount ?

    - Rajeev
    Rajeev Suri

  8. #8
    Join Date
    Feb 2001
    Posts
    203
    Yes Rajeev, I connect from svrmgrl with this command.
    connect sys/password as sysdba.

    Then it's asked me the password, I typed the same sys password and it's connected but if i typed some thing also it's connecting. I don't know whether it's asking me the sysdba password or sys password. Anyway i gave the
    startup mount but i got the same message.
    ora 01031 insufficient privileges;


    sree

  9. #9
    Join Date
    Feb 2001
    Posts
    203
    Sorry Rajeev,
    It's not a NT box! It's WIN2000 server .
    sree

  10. #10
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    okay let's try to recreate the password file --

    The password file should be in c:\oracle\ora81\database directory and the name will be pwdSID_Name.ora

    Rename this file to pwdSID_Name.old for future reference.

    Create a new file; type the following command from the DOS prompt --

    orapwd file=c:\oracle\ora81\database\pwdSID_Name.ora password=oracle

    NOTE: There is no space allowed on eaither side of the "=" character.

    This will create the password file for your SID

    Try connecting from svrmgrl now using "connect internal"

    The password for "internal" now in "oracle"

    - Rajeev
    Rajeev Suri

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width