OSD-04101: invalid SGA : SGA not initialized
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: OSD-04101: invalid SGA : SGA not initialized

  1. #1
    Join Date
    Jun 2000
    Location
    Toronto, ON, Canada
    Posts
    50
    This is the error that my client receives when try to connect to the database. It used to work OK before. I tried to reboot the machine because tha database was supposed to start automatically but I got the same message.
    The documentation for this type of error suggests that I should wait until the database is completely started, but I gor this message for about 3 days.
    Please help.
    Thanx

  2. #2
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Here is a thread from oracle metalink that talks about a similar issue:

    This is only an opinion.

    Posting from oracle metalink:
    +++++++++++++++++++++++++++++++++++++++++++++++++++

    We used on platform Wintel, NT 4 Server and Workstations,
    Oracle Server 7.3.4.

    We used database instance.
    We recreate this database with some changes.

    And here start our trouble.

    When Oracle service and instance is startup through Control
    panel, we are not to able connect to database
    (for example: SqlPlus -> ORA-01034 ORACLE not available,
    ORA-09243 smsget attaching to SGA, OSD-04101 invalid SGA:
    SGA not initialized; this message we took after one hour
    waiting too).

    When I start SVRMGR in this point, I get this result:
    Connect ... -> Connects to an idle instance.
    Shutdown ... -> ORA-01012 not loged on
    Startup ... -> LCC-00161 Oracle error parameter [NULL]
    ORA-01031 Insufficient privileges

    When Oracle instance is startup through Instance manager,
    all is right, executing same command with same parameters
    is OK.

    Here is InitSEPS.ORA
    {
    db_name = SEPS
    db_files = 100
    control_files =
    (E:\db_data\oradata\SEPS\data\ctl1SEPS.dbf,

    E:\db_data\oradata\SEPS\data\ctl2SEPS.dbf)

    rollback_segments = (RBS1,RBS2,RBS3,RBS4,RBS5,RBS6)

    compatible = 7.3.4.0.0

    db_file_multiblock_read_count = 32
    # MEDIUM
    db_block_buffers = 20000
    # MEDIUM
    shared_pool_size = 50000000
    # MEDIUM
    log_checkpoint_interval = 10000
    processes = 100
    # MEDIUM
    dml_locks = 400
    # MEDIUM
    log_buffer = 32768
    # MEDIUM
    sequence_cache_entries = 30
    # MEDIUM
    sequence_cache_hash_buckets = 23
    # MEDIUM

    SORT_AREA_SIZE = 120000
    distributed_transactions = 0
    OPEN_CURSORS = 100

    unlimited_rollback_segments = true

    # audit_trail = true # if you want auditing
    # timed_statistics = true # if you want timed
    statistics
    max_dump_file_size = 10240 # limit trace file size to
    5 Meg each

    # log_archive_start = true # if you want automatic
    archiving

    # define directories to store trace and alert files
    background_dump_dest =
    E:\db_data\oradata\SEPS\admin\bdump
    user_dump_dest =
    E:\db_data\oradata\SEPS\admin\udump
    # core_dump_dest =
    E:\db_data\oradata\SEPS\admin\cdump

    db_block_size = 4096

    nls_language = SLOVAK
    nls_territory = SLOVAKIA
    nls_sort = XCZECH

    #remote_login_passwordfile = exclusive

    text_enable = true
    }


    I dont find alert, message, error or nothing else in
    files.
    What we can do ?????????


    ------------------------------------------------------

    ORACLE_SUPPORT'S REPLY:


    Change the SID in the Registry:
    1. Run REGEDT32 and go to HKEY_Local_Machine on Local_Machine.
    2. Go to Software.
    3. Go to Oracle.
    4. Look for ORACLE_SID and verify it is set to the SID to which the you are trying to connect. If not, double click on ORACLE_SID and modify the string.

    With the wrong value in the registry, and not specifying the
    right one during connect, the software was trying to start up an SGA for a database which does not exist. You may want to try recreating the password file. Connect as
    internal and issue a startup with complete path to the PFILE.

    OR
    from the command prompt:
    set oracle_sid=SID
    svrmgr23
    svrmgr23> connect internal/password
    svrmgr23> startup pfile=



    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width