ORA-12545 Error when not specifiy SERVICE DESCRIPTOR in SQLPlus
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: ORA-12545 Error when not specifiy SERVICE DESCRIPTOR in SQLPlus

  1. #1
    Join Date
    Feb 2001
    Posts
    22
    Hi there,

    I just created a simple TNSNAMES.ORA as follow:

    oracledb =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.0.12)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = oracledb)
    )
    )

    When I use SQLPLUS username@oracledb, the SQLPlus prompt me the password and the SQLPlus can connect the Oracle successfully.

    However, when I just run SQLPLUS, the SQLPlus will return to following error once I entered username and password:

    ERROR:
    Error while trying to retrieve text for error ORA-12545

    In my environmental variable, I already setup up ORACLE_SID=oracledb.

    Anyone can solve above case?

    Regards,
    Edward.

  2. #2
    Join Date
    Feb 2001
    Posts
    49

    Talking try

    Hi

    Try this format!


    test =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL= TCP)(Host= scodb)(Port= 1521))
    (CONNECT_DATA = (SID = test))
    )

    Check the host ip address. Better to give always host name.


    HTH


  3. #3
    Join Date
    Mar 2000
    Location
    Chennai.Tamilnadu.India.
    Posts
    658

    Re:

    Hi, 15th April 2001 16:33 hrs chennai

    1) I am able to connect with this format in my system.


    NEW =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = padmam)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = new)
    )
    )

    even by providing IP address instead of host name.

    2)without using Host file i am able to connect to SQLPLUS by supplying username and pwd.

    3)Do you have more than one instance set up at your server ?

    I had the same problem too but i was unable to connect as you have said.

    With a single DB in Oracle Home dir no problem for me now.

    cheers

    Padmam



    Attitude:Attack every problem with enthusiasam ...as if your survival depends upon it

  4. #4
    Join Date
    Feb 2001
    Posts
    22

    Some more check

    Hi there,

    I enabled Net8 Trace on the client side. I found that if I use SQLPLUS username/password@testdb, the sqltrace.log show that the TNSNAMES is working properly.

    However, If I omit the username/password@testb and run SQLPLUS directly.

    I found that Net8 Client will use following method instead.

    niotns: Calling address: (DESCRIPTION=(ADDRESS=(PROTOCOL=beq)(PROGRAM=/u01/app/oracle/product/
    8.1.6/bin/oracle)(ARGV0=oracletestdb)(ARGS='(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))')(D
    ETACH=NO))(CONNECT_DATA=(CID=(PROGRAM=)(HOST=www2)(USER=oracle))))

    It seem that it can't find the testdb in the tnsnames.ora and attempt to use local connection.

    Regards,
    Edward.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width