OBJECT's option
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: OBJECT's option

  1. #1
    Join Date
    Jan 2001
    Posts
    642
    Hi,
    I have installed oracle 8.1.7 EE on the NT server. When I invoke sqlplus I get

    Oracle 8I EE Release 8.1.7.0.0. - production
    With the Partitioning option
    Jserver Release 8.1.7.0.0- Production


    However, I want to define a object type using
    create type ......AS object.

    It does not allow me to do so as I don't have the OBJECT option installed with sqlplus.

    Is there any way just to install the object option on to the sqlplus with out making any changes to all the other files like (tnsnames etc);

    Badrinath

  2. #2
    Join Date
    Aug 2000
    Posts
    194
    Hi:

    You should be able to install most of the options without affecting other installed components, using the installer.

    But before that, check the v$option whether the OBJECT option is really installed or not.



  3. #3
    Join Date
    Feb 2000
    Location
    NJ, United States
    Posts
    250

    Talking

    You have to set the parameter compatible=8.1.7
    in your initsid.ora file for the 8i parameters to take effect.

    Hope this helps


    KN

  4. #4
    Join Date
    Jan 2001
    Posts
    642
    Hi,
    Thanks for the same.

    However, in v$options ,
    I can see that "options" are true and
    In init.ora, I have made the compatable=8.1.7 (it was 8.1.0)

    Still I don't see the "options" when I invoke the sqlplus
    Badrinath

  5. #5
    Join Date
    Jan 2001
    Posts
    642
    I have also restarted the database, but don't get the object -option
    Badrinath

  6. #6
    Join Date
    Aug 2000
    Posts
    194
    I don't think it will be displayed (banner) when you invoke SQL*Plus. (Currently I am not working on Oracle EE).

    It might already have been there. Check whether there is a possible syntax error or privilege problems in creating the object.

    Also, I don't think its necessary to have the compatibe level set to 8.1.7 for OBJECT option to work. I guess, even the 8.1.5 compatibility will be fine, though the highest comaptibility is recommended for taking advantage of the new features.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width