ORA - 12514 Could not resolve service name.
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: ORA - 12514 Could not resolve service name.

  1. #1
    Join Date
    Mar 2001
    Posts
    77

    Angry

    Please help!!

    Problem:
    When I created a service using Net8 Assistant on NT the first time, I was able to create it successfully. Then I deleted it and created another. Thereafter, all the other services that I've tried to created gave me this error msg.

    ORA-12514: TNS:listener could not resolve SERVICE_NAME given in connect descriptor.

    When I attempt to connect to the database, this error shows up.

    SVRMGR> connect internal/oracle@oratest
    ORA-12154: TNS:could not resolve service name

    The paths for listener.ora, tnsnames.ora, and sqlnet.ora are correct and none of them have duplicates exist.

    Does anyone know why? Any help is greatly appreciate!

  2. #2
    Join Date
    Feb 2001
    Posts
    20
    Check the service name . Whether it is oratest or oratest.world

  3. #3
    Join Date
    Mar 2001
    Posts
    77
    I am trying to connect to a second database called ORATEST. Should this name be the same as the service name?

    I am using test8 as the service_name. Do I go to sqlnet.ora to verify ".world" exists or not? I am so new to this. Thanks for all the help!

    Originally posted by oraka6
    Please help!!

    Problem:
    When I created a service using Net8 Assistant on NT the first time, I was able to create it successfully. Then I deleted it and created another. Thereafter, all the other services that I've tried to created gave me this error msg.

    ORA-12514: TNS:listener could not resolve SERVICE_NAME given in connect descriptor.

    When I attempt to connect to the database, this error shows up.

    SVRMGR> connect internal/oracle@oratest
    ORA-12154: TNS:could not resolve service name

    The paths for listener.ora, tnsnames.ora, and sqlnet.ora are correct and none of them have duplicates exist.

    Does anyone know why? Any help is greatly appreciate!

  4. #4
    Join Date
    Oct 2000
    Location
    Charlotte, USA
    Posts
    330

    ora 12514

    Hi
    It is not recognising the sevice name...
    ensure that sevice name, Sid(datrabase) host(server) and global_name (SID.world) are correct.If not correct it.Retry it will not throw error.
    Thanks.
    thanigaivasan

  5. #5
    Join Date
    Mar 2001
    Posts
    3
    try changing Service_name to SID in your TNSnames.ora file to your SID, it should work

    bye

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width