auditing
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: auditing

  1. #1
    Join Date
    Jul 2000
    Location
    india
    Posts
    213

    Thumbs down

    Hi everybody,
    my prob is i am unable to find the audited statements in the AUD$ and its related views.
    what i did is ...
    1. set an initialization parameter AUDIT_TRAIL=TRUE
    and AUDIT_TRAIL=DB
    2. then i initiated an audit by
    AUDIT CREATE TABLE,ALTER TABLE,DROP TABLE
    BY PRASH
    WHENEVER SUCCESSFUL;
    3. I connected to user prash/prash and i created a table.
    4. then i connected to SYS and queried the AUD$ but it is giving me no rows selected.

    can anybody tell me what i am doing wrong.how do check the audited statements.any help regarding this is really appreciated.
    thanks in advance
    pras

  2. #2
    Join Date
    Mar 2001
    Posts
    12

    auditing

    Hi,

    Have you restart your database after you change the audit_trial setting?


    regards

    Tang Qiang

  3. #3
    Join Date
    Jul 2000
    Location
    india
    Posts
    213
    yeah
    i restarted the m/c also
    pras

  4. #4
    Join Date
    Feb 2001
    Location
    Bombay,India
    Posts
    530
    Hi,
    U have to set the initialisation parameter
    AUDIT_TRAIL=DB and not TRUE
    then,restart the instance

    Login as sys and give the following command
    SQL > AUDIT CREATE TABLE,ALTER TABLE,DROP TABLE
    BY PRASH whenever successful;

    Then u can see the record in the audit trail i.e SYS.AUD$ after Prash does anything with a table.

    In case of any problem,write to me at rohitsn@altavista.com

    Regards,
    Rohit nirkhe,Oracle DBA,OCP

  5. #5
    Join Date
    Jul 2000
    Location
    india
    Posts
    213
    hi rohit,
    thanks a lot.now iam getting the Audited statements in the AUD$ view.but still i am getting a prob whenever i give the follo..
    AUDIT CREATE TABLE,ALTER TABLE,DROP TABLE
    BY PRASH whenever successful;
    it gives me the error
    ORA-00990: missing or invalid privilege.

    if i give
    AUDIT CREATE TABLE,ALTER TABLE
    BY PRASH whenever successful;
    it gives me the error
    ORA-00969: missing ON keyword

    and if i give
    AUDIT CREATE TABLE
    BY PRASH whenever successful;
    then it runs successfully
    what is the prob....why the drop table and alter table options are not working ....
    pls help and once again thanks for the help
    pras

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width