DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2000
    I am trying to import the tables of an Oracle 7.3.3 EXP
    dmp file into Oracle 8.1.6 using IMP.
    Whenever I try an import the tables it gives me this
    error: "Attempting to import permanent objects into
    a temporary tablespace."
    The tablespace I created is permanent. but just to
    make sure I ran this @ the command line:

    Any suggestions as to how I can get this dump file
    imported would be greatly apperciated.

    J.Scott Adams

  2. #2
    Join Date
    Nov 2000


    do not know whether this would really solve uer problem, but it sure did for me, it goes like this,
    export uer 7.x database using a 8i export utility , then import this 8i format , dump into uer 8i database, if this is not working , there is another work around, export 7.x with an 8.0.3 export utility, then import this dump into a 8.0.3 database, then export this 8.0.3 format dump with a 8i export utility, and import this 8i format dump into uer 8i database, drop uer 8.0.3 database,pls. do read carefully, this worked for me, no reason why this should not work for u, this only could be a solution, also remember that the user in the 8i database needs to have a temporary tablespace assisgned to him explicitly, and that tablespace needs to temporary for a possible solution to this kind of problm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.