DB Link - Database link
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: DB Link - Database link

Hybrid View

  1. #1
    Join Date
    Feb 2001
    Posts
    15

    Question

    My dblink doesn´t work by sql plus client but by sql plus in server machine it works well.
    What can be??? how can i solve this problem???.

    the error message:
    SQL> select global_name from global_name@sedan.world;
    select global_name from global_name@sedan.world
    *
    ERRO na linha 1:
    ORA-03113: fim de arquivo no canal de comunicação

  2. #2
    Join Date
    Nov 2000
    Posts
    26
    hi,
    can u pls. furnish the following info.?
    1. whether uer dblink name is the same as uer global database name?
    2. that uer global database name is the same name as uer database appended with a .world?
    3. also the error u have encountered suggests 'end-of-file' which could mean sql*net commn. failure, network failure or oracle internal failure, if u can furnish more information then definitely could help.
    4. pls. do this
    SQL> select owner,dblink_name from all_db_links where dblink_name = 'your dblink name'
    SQL> select * from global.name;
    SQL> select name from v$database;
    i may not be correct on the view name, but u could find it out,
    pls. do update me with the above info. shall help
    cheers
    soren

  3. #3
    Join Date
    Feb 2001
    Posts
    15

    The global database name is sedan.world
    The db link name is sedan.world
    the db_name is sedan
    the db_domain is WORLD

    thanks for interesting Since now

  4. #4
    Join Date
    Feb 2001
    Posts
    180
    There should be a Tnsnames.ora file
    on the server as well on the client.
    It seems that only the Tnsnames.ora on the serverside
    has the info for the database-link
    Regards
    Ben de Boer

  5. #5
    Join Date
    Nov 2000
    Posts
    26
    hi,
    i am in complete agreement with ben, it appears that uer tnsnames.ora on the cleint machine is not configured for the target database, all the info. provided by u means that things are ok with the dblink(that was true anyhow or else uer dblink would not have worked from the server), just made myself clear on the issue
    cheers
    soren

  6. #6
    Join Date
    Feb 2001
    Posts
    15
    i dont ´t really understand the why it isn´t work because the client is configured identical to the server..
    detail: my initial domain was dspsrv004. and i changed is there any problem in do that???

    the configuration

    SEDAN.WORLD =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (COMUNITY=WORLD)
    (ADDRESS = (PROTOCOL = TCP)(HOST = 9.179.100.13)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = sedan)(GLOBAL_NAME=SEDAN.WORLD)
    )
    )

  7. #7
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    If your dblink name is diffrent from service name you are using , you should set global_names=false in init.ora
    Reddy,Sam

  8. #8
    Join Date
    Feb 2001
    Posts
    15
    Did U think the service_name must be sedan.world???

  9. #9
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Yes. Your service_name and dblink name should be same if your init.ora global_names is set to TRUE. Otherwise have diffrenet dblink_name than your service_name and set that parameter FALSE.
    Reddy,Sam

  10. #10
    Join Date
    Feb 2001
    Posts
    15
    this morning i set global_names false and it isn´t work. I don´t know more what to do. thanks for the help friends..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width