Deinstall Webdb
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 10 of 10

Thread: Deinstall Webdb

  1. #1
    Join Date
    Nov 2000
    Posts
    173
    Hi everyone,

    I am needing to deinstall Webdb. I did not install it, so the uninstall process is boggling me. I am working with Oracle 8.1.6 and UNIX system.

    Steps, suggestions appreciated.

    Thx

  2. #2
    Join Date
    Jan 2001
    Posts
    642
    The bestway will be to delete the directory 'webdb' and do the installation again
    This worked for me on ora 8.0.5, webdb 2.X

    Badrinath

  3. #3
    Join Date
    Nov 2000
    Posts
    173
    thanks,

    I wanted to completely deinstall webdb and not reinstall.

    So if I delete the directory on UNIX thats it! Sounds to easy. Are there any other items I would need to delete. I want to clean up any trace of Webdb.

    thx
    kathy

  4. #4
    Join Date
    Jan 2001
    Posts
    642
    Any thing that you create using webdb will be under this particular webdb - directory. So I feel by removing the directory may remove all the traces also. And if req, you can retain the virtual directoris created.
    Badrinath

  5. #5
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    NOT TRUE. You better follow deinstallation steps from WebDB docs or Metalink doc. It will never be true.... Any Product installation will update the system files on any operating system. The only way you clean/uninstall the product is by following the procedure or by manually finding the locations of alll the file changes that were reflected with the installation.

    Reddy,Sam

  6. #6
    Join Date
    Nov 2000
    Posts
    173
    Thanks,

    I have been searching everywhere for instructions on webdb deinstallation. I am sure its out there, but all I can find is an NT version (inside the install guide). I need a UNIX deinstall. Can anyone direct me to a paper, directions or location for this?



  7. #7
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Kathy,

    Iam not familiar with WebDB architecture on Unix,to help you. Did you try Metalink? Does Oracle doesn't provide any toll like Unversal Installer ? If you are keen on doing it right way(obviously) why don't you log a TAR with Oracle and you can help us knowing how to do that. Right ?

    I'm sure you could find something on Metalink. Deinstallation of any vendor product is common in day to day life of an IT consultant. There will be some document...

    Reddy,Sam

  8. #8
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    You can do the following. for the most clean uninstall

    0. Stop all your webdb listeners.

    1. Remove the directory of webdb from unix

    rm -rf webdb

    2. When you had installed the webdb, you would have created a repository on the database. There would be a user name
    WEBSYS and remove that user and if you are sure that you had put this user unser a dedicated tablespace, you can drop that tablespace too. If not, just dropping the user would drop the entire webdb schema, that was created on the database

    It had been a long time since I played with the webdb, but quiet sure that this would do the most clean install to my knowledge.

    Good luck
    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  9. #9
    Join Date
    Nov 2000
    Posts
    173
    Thanks for good advice,

    While was waiting, I started the installer and selected all webdb products to remove, figured I would then go to unix and delete directories. Installer ran for a while deleting some products, then a prompt for the sys password and tns alias came up. I have tried what it should be and everything else I can think of. Does anyone know why its not acceptting my password or tnsalis?

    To test the password I tried to log into sqlplus under webdb env but sqlplus has already been deleted. This same password does work on the 8.1.6 env.

    I checked the tnsalias in the tnsnames files, looks good.

    Any Ideas?


  10. #10
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    It could be because the installer had removed the sqlplus. Try running the installer again and try doing the uninstall, but make sure that you give the sys and the sys password correctly. Because, this is needed to remove the webdb schema on the database. Also make sure that you have the tns_admin=$ORACLE_HOME/network/admin setted up on your profile. This would help to pin point the location of the tnsnames.ora file location.

    Hope this would help you.
    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width