db_link error
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: db_link error

  1. #1
    Join Date
    Feb 2001
    Posts
    23
    hi

    i create db_link ...(db_link created)
    i use SELECT * FROM DEPT@db_link_name;

    gives me error TNS:COULD NOT RESOLVE SERVICE NAME

    i try to connect to remote db using ...
    CONNECT USER/PWD@DB_NAME2 and i get connected
    pls help me to fix this step by step please.....
    what should i have on my tnsname.ora?example pls..

    thank for help....

  2. #2
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Post steps you have followed for creating dblink with syntax.
    Reddy,Sam

  3. #3
    Join Date
    Feb 2001
    Posts
    180
    When using a dblink, the definition must also exists in TNSNAME.ORA at the serverside.
    Regards
    Ben de Boer

  4. #4
    Join Date
    Feb 2001
    Location
    Paris, France
    Posts
    809
    when creating a DB*Link, the syntax should be :

    create database link mylink
    connect to user
    identified by pwd
    using 'connect_string';

    and this connect string must be in your tnsnames.ora, if not you get the famous 12154 error ...

  5. #5
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    See the following thread and refer for my posting to see the syntax of create dblink.

    [url]http://www.dbasupport.com/forums/showthread.php?threadid=6584[/url]
    Reddy,Sam

  6. #6
    Join Date
    Feb 2001
    Posts
    15
    Hi,
    In init.ora file change global_names=false and source server and configure you tnsnames.ora to connect to the destination server.

    Regards,
    yajman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width