Getting error during import -URGENT
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Getting error during import -URGENT

  1. #1
    Join Date
    Feb 2001
    Posts
    27

    Exclamation


    Hi there,

    I have a database of version 8.1.5 on unix sun-solaris(5.8). I've upgrdaed this from 8.0.6 couple of days ago. After upgrading, I export the database and import it to another database of 8.1.5 as before. After upgradation, export is fine. when I import to another database, it imports all the rows, indexes etc. but i'm getting the following error:

    . . importing table "TEMP_MULTI_4A" 85948 rows imported
    IMP-00017: following statement failed with ORACLE error 20001:
    "DECLARE SREC DBMS_STATS.STATREC; BEGIN SREC.MINVAL := NULL; SREC.MAXVAL :="
    " NULL; SREC.NOVALS := DBMS_STATS.NUMARRAY(202371,2973729); SREC.BKVALS := D"
    "BMS_STATS.NUMARRAY(0,1); SREC.EPC := 2; DBMS_STATS.SET_COLUMN_STATS(NULL,'T"
    "EMP_MULTI_4A','SHRFNBR',NULL,NULL,NULL,84919,.0000117759276487005,0,srec,-4"
    "325375,0); END;"
    IMP-00003: ORACLE error 20001 encountered
    ORA-20001: Invalid or inconsistent input values
    ORA-06512: at "SYS.DBMS_STATS", line 1669
    ORA-06512: at line 1
    IMP-00017: following statement failed with ORACLE error 20001:
    "DECLARE SREC DBMS_STATS.STATREC; BEGIN SREC.MINVAL := NULL; SREC.MAXVAL :="
    " NULL; SREC.NOVALS := DBMS_STATS.NUMARRAY(1,4); SREC.BKVALS := DBMS_STATS.N"
    "UMARRAY(0,1); SREC.EPC := 2; DBMS_STATS.SET_COLUMN_STATS(NULL,'TEMP_MULTI_4"
    "A','OCOUNT',NULL,NULL,NULL,4,.25,0,srec,-4325375,0); END;"
    IMP-00003: ORACLE error 20001 encountered
    ORA-20001: Invalid or inconsistent input values
    ORA-06512: at "SYS.DBMS_STATS", line 1669
    ORA-06512: at line 1

    Anybody has any idea - please it's urgent.

    Thanks
    babu

  2. #2
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    After import did you compile all the invalid packages of SYS and SYSTEM or Not ? If not do that on the upgraded machine. Its very important when you do import from one version to another.

    You have to run catalog.sql and catproc.sql as sys/internal if you are upgrading from version to version like 7 to 8/8 to 8i.

    See this Helps..
    Reddy,Sam

  3. #3
    Join Date
    Feb 2001
    Posts
    27
    Hi Sreddy,

    Thanks for your reply.

    Just for your kind information, now both the databases are in 8.1.5 version.

    During Upgradation, I ran u0800050.sql script which includes both the catalog.sql and catproc.sql in both the databases. In addition to that, I ran utlrp.sql script in both the databases to recompile the procedures.

    Please let me know what else do I need to do.

    Thanks
    in advance

    Regards
    Babu

  4. #4
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    There is nothing you loose by recompiling all and running catalog.sql and catproc.sql. Go ahead and redo those steps on the upgrade database and try export and import.

    Just check for any duplicate packages in system and sys users. I wonder some conflicts with dbms_packages.

    See this helps and post back errors if you still have problems.
    Reddy,Sam

  5. #5
    Join Date
    Feb 2001
    Posts
    27

    Thanks Sreddy.

    I'll run both of them and get back to you tomorrow morning.

    Thanks
    Babu

  6. #6
    Join Date
    Oct 2000
    Location
    Cambridge, MA (Boston)
    Posts
    144
    there were some bugs in 8.1.5 with the importation of statistics. i can't remember the specifics, but try exporting with STATISTICS=NONE

    I found this note in one of my export scripts: use statistics=NONE in 8.1.5 due to import bug 900811

    check it out on metalink

    d.

  7. #7
    Join Date
    Feb 2001
    Posts
    27

    Hi Sreddy,

    I ran catalog.sql, catproc.sql and utlrp.sql yesterday. But I've got the same error.

    I haven't apply DBATRIX's suggestion yet (Statistics=none), hopefully I'm going to apply this parameter tonight.

    Let see what happens.

    If you or anybody has any other suggestion in addition to this, please let me know.

    Thanks
    Babu

  8. #8
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Did youi check for any duplicate packages on sys and system users ? Run this query and check .

    <font face=courier>
    col owner format a12
    col object_name format a32
    col object_type format a16
    select owner, object_name, status, object_type
    from dba_objects
    where object_name in (select object_name
    from dba_objects
    where
    owner = 'SYSTEM' and
    object_name in (select object_name
    from dba_objects where owner = 'SYS'))
    and owner in ('SYS', 'SYSTEM')
    and object_type like 'PACKAGE%'
    order by object_name, object_type
    /
    </font>


    I don't think dup objects are the problem... something goofy. Not even relevant error message for ORA 20001. Did you serach metalink ?


    [Edited by sreddy on 02-16-2001 at 12:49 PM]
    Reddy,Sam

  9. #9
    Join Date
    Feb 2001
    Posts
    27
    Hi Sreddy,

    I checked it yesterday and again today with your query but no duplicate packages.

    I searched in the metalink, I found one topic with the same error like me, but it finished half way through - no specific answer.

    Thanks
    Babu

    [Edited by rafiq on 02-20-2001 at 12:03 PM]

  10. #10
    Join Date
    Feb 2001
    Posts
    27
    It's great. It's cool.

    Thank you, DBATrix a lot.

    Regards
    Babu


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width