importing from 8.1.6 to 7.3.4
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: importing from 8.1.6 to 7.3.4

  1. #1
    Join Date
    Oct 2000
    Posts
    56
    hello all,

    I need to import an 8.1.6 db into a 7.3.4 db... are there any precautions i should know about, or is this possible?

  2. #2
    Join Date
    Jan 2001
    Posts
    230
    Hi

    As far as I know they have changed the binary format in 8i so if you exp. from 8.1.5
    and imp to 7.3.4, most likely it will not work.
    To make sure I have asked this question, nobody has answered yet.
    For more detail check "maxxx"


  3. #3
    Join Date
    Oct 2000
    Posts
    34

    No problem

    You can run catexp7.sql ($ORACLE_HOME/rdbms/admin). And export database by export version 7 (from any client)...

  4. #4
    Join Date
    Sep 2000
    Posts
    384
    You have to run the catexp7 .then export and do the import...
    Radhakrishnan.M

  5. #5
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    You guys have been taking so easily about downgrading the version of the database. The data types have been changed.(example LONG, LONGRAW is no more valid on 8x and above)
    What makes you sure that 8i database is not using the new data types. If so how are you going to handle those new datatypes. You get "unsupported network data type error" the moment you import.

    Keeping in mind that I suggested, Chrissy to get in touch with Oracle and find pitfalls before attempting to do that.

  6. #6
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    Sreddy, LONGs and LONGRAWs are still supported in 8.x, no problem there. But if the database has LOBs in use, then AFAIK there is no way to convert them back to LONGs, so those tables will not be able to be imported down to 7.x. Also, if you have VARCHAR2 columns defined greater than 2000 you will have troubles. But all this can be resolved by DBA with some compromises, so you can't say that exp-imp from 8.x down to 7.x is something that can be done in general or that you need Oracle Support assistance for that. Exporting from higher version and importing to lower version is totaly viable and documented option, you just have to be avare what can not be created/implemented in lover version.
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  7. #7
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Thanks Jmodic for correcting me,

    I was assumption that, LOBS are in replacement to LONG datatype and part of Object relational features. I was not aware that those data types are still compatible with 8x.

    I don't remember exactly, I hit the same situation few months back from 8.0.5 to 7.3.4 and had problems. We were getting the unsupported network dtatatype error. We endup not downgrading but, upgrading the vendor application that supports 805.

    [Edited by sreddy on 02-01-2001 at 07:39 PM]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width