Switchover_status is not allowed in standby
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Switchover_status is not allowed in standby

  1. #1
    Join Date
    Apr 2009
    Posts
    54

    Switchover_status is not allowed in standby

    Hi folks,

    i have configured standby database for oracle 11g (11.2.0.1.0) on AIX 6.1 .i have not check the switch over or failover , as the primary database is Production

    but when i checked

    @Primary side:

    SQL> select switchover_status from v$database;

    SWITCHOVER_STATUS
    --------------------
    TO STANDBY

    SQL> select max(sequence#) from v$archived_log where applied='YES';


    MAX(SEQUENCE#)
    --------------
    2563

    @Standby Side


    SQL> select switchover_status from v$database;


    SWITCHOVER_STATUS
    --------------------
    NOT ALLOWED


    SQL> select max(sequence#) from v$archived_log where applied='YES';


    MAX(SEQUENCE#)
    --------------
    2563


    but i google about SWITCHOVER_STATUS is NOT ALLOWED but it says
    NOT ALLOWED - Either this is a standby database and the primary database has not been switched first, or this is a primary database and there are no standby databases.

    i have checked the DR syn is fine ,RFS is working fine , archive are being applied on DR


    so please let me know in future if business permits can i switch over and do the testing and switch back to primary with the same setting.

    appreciate your prompt response .


    Regards.

  2. #2
    Join Date
    Nov 2000
    Location
    Pittsburgh, PA
    Posts
    4,159
    You should make sure that you have both online redo logs and standby redo logs.

    http://docs.oracle.com/cd/B28359_01/...6.htm#CHDDHGBE
    this space intentionally left blank

  3. #3
    Join Date
    Feb 2014
    Posts
    22
    switchover_status not allowed on the standby can be.
    If you are sure logfiles are applied then switchover still be possible.
    You should worry if the status ‘NOT ALLOWED’ would be not on the primary database as that would mean there are no other databases.
    When I builded my production site I at the same time builded my standby dataguard. Before put it into production I tested the switchover several times. It worked although the status on the standby gives me ‘NOT ALLOWED’.
    Most important things are:
    Check the standby alertlog file if the archive log files are really applied. Media recovery has to take place.
    Use the dataguard manager:
    D:\]dgmgrl
    DGMGRL for 64-bit Windows: Version 11.2.0.1.0 - 64bit Production
    Copyright (c) 2000, 2009, Oracle. All rights reserved.
    Welcome to DGMGRL, type "help" for information.
    DGMGRL> connect sys/password
    Connected.

    DGMGRL> SHOW CONFIGURATION
    Configuration – database services
    Protection Mode: MaxPerformance
    Databases:
    DATABASE1 - Primary database
    DATABASE2 - Physical standby database
    Fast-Start Failover: DISABLED
    Configuration Status:
    SUCCESS

    DGMGRL> show database verbose 'DATABASE1';
    Database – DATABASE1
    Enterprise Manager Name: DATABASE1
    Role: PRIMARY
    Intended State: TRANSPORT-ON
    Instance(s):
    Database1
    Database2
    Properties:
    DGConnectIdentifier = 'DATABASE1'
    ObserverConnectIdentifier = ''
    LogXptMode = 'arch'
    DelayMins = '0'
    Binding = 'optional'
    MaxFailure = '0'
    MaxConnections = '1'
    ReopenSecs = '300'
    NetTimeout = '15'
    RedoCompression = 'DISABLE'
    LogShipping = 'ON'
    PreferredApplyInstance = 'database1'
    ApplyInstanceTimeout = '0'
    ApplyParallel = 'AUTO'
    StandbyFileManagement = 'AUTO'
    ArchiveLagTarget = '900'
    LogArchiveMaxProcesses = '4'
    LogArchiveMinSucceedDest = '1'
    DbFileNameConvert = ''
    LogFileNameConvert = ''
    FastStartFailoverTarget = ''
    StatusReport = '(monitor)'
    InconsistentProperties = '(monitor)'
    InconsistentLogXptProps = '(monitor)'
    SendQEntries = '(monitor)'
    LogXptStatus = '(monitor)'
    RecvQEntries = '(monitor)'
    HostName(*)
    SidName(*)
    StaticConnectIdentifier(*)
    StandbyArchiveLocation(*)
    AlternateLocation(*)
    LogArchiveTrace(*)
    LogArchiveFormat(*)
    TopWaitEvents(*)
    (*) - Please check specific instance for the property value
    Database Status:
    SUCCESS

    DGMGRL> show database verbose ' DATABASE2'; (standby database)
    Database – DATABASE2
    Enterprise Manager Name: standby service
    Role: PHYSICAL STANDBY
    Intended State: APPLY-ON
    Transport Lag: 0 seconds
    Apply Lag: 14 minutes 20 seconds
    Real Time Query: OFF
    Instance(s):
    nlvenwms
    Properties:
    DGConnectIdentifier = 'DATABASE2'
    ObserverConnectIdentifier = ''
    LogXptMode = 'arch'
    DelayMins = '0'
    Binding = 'OPTIONAL'
    MaxFailure = '0'
    MaxConnections = '1'
    ReopenSecs = '300'
    NetTimeout = '15'
    RedoCompression = 'DISABLE'
    LogShipping = 'on'
    PreferredApplyInstance = ''
    ApplyInstanceTimeout = '0'
    ApplyParallel = 'AUTO'
    StandbyFileManagement = 'auto'
    ArchiveLagTarget = '900'
    LogArchiveMaxProcesses = '4'
    LogArchiveMinSucceedDest = '1'
    DbFileNameConvert = ''
    LogFileNameConvert = 'null, null'
    FastStartFailoverTarget = ''
    StatusReport = '(monitor)'
    InconsistentProperties = '(monitor)'
    InconsistentLogXptProps = '(monitor)'
    SendQEntries = '(monitor)'
    LogXptStatus = '(monitor)'
    RecvQEntries = '(monitor)'
    HostName = 'dataguardserver'
    SidName = 'databaseserver'
    StaticConnectIdentifier = '(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=dataguardserver)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=d ataguardservicename)(INSTANCE_NAME=’instancename’)(SERVER=DEDICATED)))'
    StandbyArchiveLocation = 'USE_DB_RECOVERY_FILE_DEST'
    AlternateLocation = ''
    LogArchiveTrace = '0'
    LogArchiveFormat = 'ARC%S_%R.%T'
    TopWaitEvents = '(monitor)'
    Database Status:
    SUCCESS

    DGMGRL>

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width