Control files recreate..!!
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Control files recreate..!!

  1. #1
    Join Date
    Oct 2000
    Posts
    467
    Hi,
    I'm running Oracle 8.1.5 on Solaris platform. I was just testing out some recovery scenarios. I deleted my control files and tried to re-create it using the backup control file. My database was running in archivelog mode and was shutdown normal before deleting my control files. I'm getting the foll. error. Could u pls help me out..?

    1. Startup nomount
    2. CREATE CONTROLFILE REUSE DATABASE "VTEST" NORESETLOGS ARCHIVELOG
    MAXLOGFILES 32
    MAXLOGMEMBERS 2
    MAXDATAFILES 800
    MAXINSTANCES 2
    MAXLOGHISTORY 226
    LOGFILE
    GROUP 1 '/dbase1/u14/oradata/vtest/logs/log1.dbf' SIZE 1M,
    GROUP 2 '/dbase1/u14/oradata/vtest/logs/log2.dbf' SIZE 1M
    DATAFILE
    '/dbase1/u14/oradata/vtest/data/system.dbf',
    '/dbase1/u14/oradata/vtest/data/rbs.dbf',
    '/dbase1/u14/oradata/vtest/data/temp.dbf',
    '/dbase1/u14/oradata/vtest/data/users.dbf'
    CHARACTER SET WE8DEC

    After running the script , I'm getting the foll. error :-

    CREATE CONTROLFILE REUSE DATABASE "VTEST" NORESETLOGS ARCHIVELOG
    *
    ORA-01503: CREATE CONTROLFILE failed
    ORA-01160: file is not a data file
    ORA-01110: data file : '/dbase1/u14/oradata/vtest/data/system.dbf'
    SVRMGR>

    Could u pls help me sort out this problem. No changes've been made to any of the files.

    Thanx
    Vinit

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Does '/dbase1/u14/oradata/vtest/data/system.dbf' exist?

    Do you have the correct permission on '/dbase1/u14/oradata/vtest/data/system.dbf' ?
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Mar 2000
    Location
    CA
    Posts
    317
    Check the path, permitions on SYSTEM.mdf
    Thanks
    Kishore Kumar

  4. #4
    Join Date
    Oct 2000
    Posts
    467

    Wink All ok..!!

    Hi,
    Sorry Guys..!! The problem was b'coz of using a different init.ora. I had just given startup nomount instead of the foll.
    Startup nomount pfile=initvtest.ora.

    Since, this is a test database, my init file was not in the ORACLE_HOME directory.

    Thanx for the help though..!!

    Regards,
    Vinit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width