I created a script to make my admin server a windows service. I successfully made it a service but when it starts it then shuts itself down. i ran a debug and found a error. I dont get what to do. I have tried changing the variables in the script and try it over and over again .....here is my script code and here is the error i got from debug output:

script

SETLOCAL

set DOMAIN_NAME=FRClassicDomain

set USERDOMAIN_HOME=C:/Oracle/Middleware/user_projects/domains/FRClassicDomain

set SERVER_NAME=FRweblogic

set WLS_USER=FRweblogic

set WLS_PW=hidden

set ADMIN_URL=http://hidden:hidden

set JAVA_VENDOR=Sun

set JAVA_HOME=C:/Program Files/Java/jdk1.7.0

set PRODUCTION_MODE=true

set MEM_ARGS=-Xms512m Xmx512m

call "C:/Oracle/Middleware/user_projects/domains/FRClassicDomain/bin/setDomainEnv.cmd"

call "C:/Oracle/Middleware/wlserver_10.3/server/bin/installSvc.cmd"

ENDLOCAL

my debug output:

...............

There are 1 nested errors:

weblogic.management.ManagementException: [Management:141223]The server name FRwe
blogic specified with -Dweblogic.Name does not exist. The configuration includes
the following servers {AdminServer,WLS_FORMS,WLS_REPORTS,FRasserver}.
at weblogic.management.provider.internal.RuntimeAccessImpl.(Runtim
eAccessImpl.java:149)
at weblogic.management.provider.internal.RuntimeAccessService.start(Runt
imeAccessService.java:41)
at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesMan
ager.java:461)
at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServ
icesManager.java:166)
at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:881)
at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:568)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)
at weblogic.Server.main(Server.java:71)


te changed to FAILED>
te changed to FORCE_SHUTTING_DOWN>

C:\Oracle\Middleware\wlserver_10.3\server\bin>