Oracle 10g on Windows 7 64-bit machine
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Oracle 10g on Windows 7 64-bit machine

Hybrid View

  1. #1
    Join Date
    Jul 2012
    Posts
    2

    Oracle 10g on Windows 7 64-bit machine

    Hi,

    I am not a DBA but since the DBA in our team is out sick and this is urgent I thought this forum could help me. I tried to install oracle 10g on my PC which has windows 7 64bit OS. My first question is that when we install oracle client on any machine is an entry made in windows registry under HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE
    Because there is no such entry on my machine. Is that a red flag?
    Also, when I installed oracle client from the CD, there was no TNSNAMES.ora file created by default in the ADMIN folder. I went and placed one in there. Is a default file always created the first time we install the client?

    Secondly, when I try to connect crsytal reports 2008 to oracle, it throws the ORA 12154 error.

    Please help!!

  2. #2
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    I understand you are intalling Oracle client in that machine, is that correct?

    Have you set ORACLE_HOME and ORACLE_SID before attempting the connection?

    Can you PING the target database server?

    Can you TNSPING the target database?
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  3. #3
    Join Date
    Jul 2012
    Posts
    2
    Yes I am able to TNS PING the target database. Where do I need to set ORACLE_HOME and ORACLE_SID and what should their entries be?

  4. #4
    Join Date
    Mar 2006
    Location
    Charlotte, NC
    Posts
    865
    If you haven't found so far, you need to set the environment variables in system variables area.

    Right click on My Computer -> Properties -> Advanced -> Environment Variables -> Syatem Variables

    Regards,
    Vijay Tummala

    Try hard to get what you like OR you will be forced to like what you get.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width