Oracle Patchset Issue - Page 2
DBAsupport.com Forums - Powered by vBulletin
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Oracle Patchset Issue

  1. #11
    Join Date
    Dec 2010
    Posts
    11
    Hi,

    Please bear with me, I am very new at Oracle but willing to work at it. So with other software patches (i.e. MS SQL), running a service pack or a patch does not typically affect the contained databases. Are you telling me that going from 10.2.0.1 to 10.2.0.5 in Oracle requires more additional steps? Is there an article that I should read to figure out how to perform this upgrade properly? (I read the read me that came with it already, but perhaps I don't understand it all)

    I created a starter database when I installed 10.2.0.1, and then just ran the patchset. Can you tell me where I would go from here? I'd like to know how to properly upgrade an existing db instance and get it running again (continuing from startup upgrade), but I'd also like to know how to recreate the starter database again from scratch too (is it just using create database commands? If so what do I do with the existing non-working db?).

    Thanks.
    Last edited by dontinou; 12-27-2010 at 04:15 PM.

  2. #12
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Installing an Oracle patchset is not rocket science but it is not trivial either.

    Which patchset are you applying? is it 8202632?
    Are you positive you have read, understood and follow step by step readme guide?
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  3. #13
    Join Date
    Dec 2010
    Posts
    11
    OK so I ran this:

    startup upgrade
    spool patch.log
    @?/rdbms/admin/catactx.sql (see patch.txt)
    spool off
    @?/rdbms/admin/utlrp.sql (see recompile.txt - funny error at SYS.UTL_RECOMP)
    shutdown immediate
    startup

    still get ORA-01092 error..
    Attached Files Attached Files

  4. #14
    Join Date
    Dec 2010
    Posts
    11
    Quote Originally Posted by PAVB View Post
    Installing an Oracle patchset is not rocket science but it is not trivial either.

    Which patchset are you applying? is it 8202632?
    Are you positive you have read, understood and follow step by step readme guide?
    Yes that is the one. I'll go back and read the read me again.. I didn't know you had to upgrade each db afterwards so I probably missed something. tx

  5. #15
    Join Date
    Dec 2010
    Posts
    11
    Quote Originally Posted by PAVB View Post
    Installing an Oracle patchset is not rocket science but it is not trivial either.

    Which patchset are you applying? is it 8202632?
    Are you positive you have read, understood and follow step by step readme guide?
    Hi,

    OK I ran the Database Upgrade Assistant and EM works fine now!!!

    Question, the following components failed during the upgrade:

    Data Mining
    OLAP Analytic Workspace
    OLAP Catalog
    Oracle OLAP API
    Spatial

    Is this normal for an Oracle Standard Edition?

    Also, now that the server is upgraded to 10.2.0.5, do I need the corresponding 10.2.0.5 client? Where do I download it? I only see client files for 10.2.0.3... does it matter?

    Thanks

  6. #16
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Quote Originally Posted by dontinou View Post
    Hi,

    OK I ran the Database Upgrade Assistant and EM works fine now!!!

    Question, the following components failed during the upgrade:

    Data Mining
    OLAP Analytic Workspace
    OLAP Catalog
    Oracle OLAP API
    Spatial

    Is this normal for an Oracle Standard Edition?

    Also, now that the server is upgraded to 10.2.0.5, do I need the corresponding 10.2.0.5 client? Where do I download it? I only see client files for 10.2.0.3... does it matter?

    Thanks
    Good job!

    In regard to your questions...

    1- Yes... Data Mining, OLAP, etc are not supported features on Standard Edition - check item 15.1 on readme guide; everything is there!!!

    2- No need to install client 10.2.0.5 - any client from Ora9i (actually Oracle 8.1.7) to Ora11g will connect to Oracle 10.2.0.5
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  7. #17
    Join Date
    Dec 2010
    Posts
    11
    That's perfect. Thanks for helping me figure it out, I can get back to my vacation now!!

    Happy holidays to you.

  8. #18
    Join Date
    Dec 2010
    Posts
    12
    dontinou,

    After upgrading the binaries, did you follow the POST-UPGRADE procedures in the README? If not, why not? When dealing with patching and upgrades, you MUST follow the README explicitly or you may risk trashing your database - and hopefully it is not a production database.

    On this "windows" crap, you apparently are not accustomed to actually reading the instructions. With Oracle, if you don't read the instructions you could severely cripple your system as the instructions are NOT necessarily the same for "the next patch". And if you have RAC - it is even more imperative that you do so.

  9. #19
    Join Date
    Dec 2010
    Posts
    11
    Quote Originally Posted by onedbguru View Post
    dontinou,

    After upgrading the binaries, did you follow the POST-UPGRADE procedures in the README? If not, why not? When dealing with patching and upgrades, you MUST follow the README explicitly or you may risk trashing your database - and hopefully it is not a production database.

    On this "windows" crap, you apparently are not accustomed to actually reading the instructions. With Oracle, if you don't read the instructions you could severely cripple your system as the instructions are NOT necessarily the same for "the next patch". And if you have RAC - it is even more imperative that you do so.
    Gee, and I was just thinking how helpful people were on this forum. Good to know you have so much time on your hands that you feel the need to flame resolved threads only to add zero value to the conversation. Hope that makes you feel smarter .

    This will be my only reply, but let me leave you with a fact of life, dear boy. Just because something is tedious and complicated doesn't mean it's good, and it's because of narrow minded grunts like you that the world is kosher with poor software design.

    Write this on your forehead: It's when you don't have to read the instructions, when things just work as expected, that true genius is found. You think the iPhone would be the fastest selling consumer product in history if it came with a 200 page read-me, that if not read, would "severely cripple the system"? lol.

    Sorry to burst your bubble, but someone has to teach you.

    Merry Christmas!
    Last edited by dontinou; 12-27-2010 at 09:31 PM.

  10. #20
    Join Date
    Dec 2010
    Posts
    12
    My apologies for not seeing where it was resolved prior to posting. That being said, having had to recover too many databases to count due to others not reading the instructions, I find it useful to start the "help" lessons there. and after reading the "resolution", they look vaguely familiar to the instructions in the README.

    Not a Windows point-n-click weenie...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width