Imp error: ORACLE error 1400 encountered - Page 2
DBAsupport.com Forums - Powered by vBulletin
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Imp error: ORACLE error 1400 encountered

  1. #11
    Join Date
    Oct 2008
    Location
    Chandigarh, India
    Posts
    322
    Quote Originally Posted by vnktummala View Post
    yes, you have multiple ways to do that.

    but, first place I am wordaring why imp is trying to insert null values. Because I am sure the NOT NULL constraint is there on the source table so no chance of having null values in source. Does it mean that the BLOB column data is not exported??

    as the other poster said, drop that table with cascade constraints and let imp create the table and see how it goes.

    Thanks,
    I am arranging some more disk space as I am running out of it. Though I dropped the entire schema and tried import again.
    I will try to do it the way as I suggested in my previous post and then let you know.
    lucky

  2. #12
    Join Date
    Oct 2008
    Location
    Chandigarh, India
    Posts
    322
    1.I am not even able to import only MAM_ASSETS table without indexes and constraints. It gets stuck with the same error, probably because create table clause for MAM_ASSETS contains NOT NULL clause for columns INDEX_SOURCE and FTS_TEXT.


    2. However, I also got the CREATE TABLE MAM_ASSETS using SHOW=Y option of imp. Using this, I manually created the MAM_ASSETS table and deleted the NOT NULL clauses for problematic columns. Then I tried to re-import the remaining data using IGNORE=Y option of IMP. Ideally, it should have imported the rows in MAM_ASSETS table but even it also returns the same error as posted in my first post.
    Following this, I saw the description of MAM_ASSETS table to see if there is no NOT NULL constraint on the MAM_ASSETS table. To my surprise, these columns had NOT NULL constraint present on them. Should it have happened? I think no because the create table statement should have been ignored without errors and the rows should have gotten imported.


    Any help would he highly appreciated.
    lucky

  3. #13
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Lets try a step-by-step guide...

    Please follow guide and spool off eveything you do - in case something happens we will appreciate to see whole session.

    1- Drop MAM_ASSETS table
    2- Create MAM_ASSETS - be sure no column has NOT NULL option
    3- desc MAM_ASSETS
    4- import MAM_ASSETS with options... ignore=y indexes=n constraints=n
    5- desc MAM_ASSETS
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  4. #14
    Join Date
    Oct 2008
    Location
    Chandigarh, India
    Posts
    322
    Quote Originally Posted by PAVB View Post
    Lets try a step-by-step guide...

    Please follow guide and spool off eveything you do - in case something happens we will appreciate to see whole session.

    1- Drop MAM_ASSETS table
    2- Create MAM_ASSETS - be sure no column has NOT NULL option
    3- desc MAM_ASSETS
    4- import MAM_ASSETS with options... ignore=y indexes=n constraints=n
    5- desc MAM_ASSETS

    Still receiving the same error.
    But the NOT NULL constraints for columns don't come after importing rows of table. Attached is the spool file.
    Some 8,28,000 rows get imported and the following error gets generated repetitively for 20-25 times during import.

    Import: Release 10.1.0.2.0 - Production on Mon May 17 17:35:34 2010

    Copyright (c) 1982, 2004, Oracle. All rights reserved.


    Connected to: Oracle Database 10g Enterprise Edition Release 10.1.0.2.0 - Production
    With the Partitioning, OLAP and Data Mining options

    Export file created by EXPORT:V09.02.00 via conventional path

    Warning: the objects were exported by SYSTEM, not by you

    import done in WE8MSWIN1252 character set and AL16UTF16 NCHAR character set
    . . importing table "MAM_ASSETS"
    IMP-00019: row rejected due to ORACLE error 1400
    IMP-00003: ORACLE error 1400 encountered
    ORA-01400: cannot insert NULL into ("QUARKDMS"."MAM_ASSETS"."INDEX_SOURCE")
    Column 1 413212
    Column 2 65678
    Column 3 65780
    Column 4 21
    Column 5
    Column 6 2
    Column 7 0
    Column 8 1
    Column 9 1
    Column 10 1
    Column 11 0
    Column 12 412553
    Column 13 4
    Column 14
    Column 15 7 5 E 20 19
    Column 16 7 5 e 20 19
    Column 17
    Column 18
    Column 19 25902
    Column 20 2
    Column 21 30-AUG-2002:13:26:54
    Column 22
    Column 23 30-AUG-2002:13:26:54
    Column 24
    Column 25 10-SEP-2002:10:14:13
    Column 26 JPEG
    Column 27 14-OCT-2005:14:49:58
    Column 28 jpeg
    Column 29 8BIM
    Column 30
    Column 31 8bim
    Column 32 65780
    Column 33 65715
    Column 34 65874
    Column 35 65617
    Column 36 005400010108000000010000000100000009158700000A3C00...
    Column 37
    Column 38 14-OCT-2005:14:49:58
    Column 39 1
    Column 40 65874
    Column 41 02-SEP-2002:13:28:51
    Column 42
    Column 43
    Column 44 005400010208000000010000000100000025B2330008AA8200...
    Column 45 US


    No NOT NULL on INDEX_SOURCE, still it is not allowing import of rows.
    PS: INDEX_SOURCE is a BLOB column.
    Attached Files Attached Files
    Last edited by mahajanakhil198; 05-17-2010 at 10:40 AM. Reason: Added more information.
    lucky

  5. #15
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Now that we can see... we can help better.
    Are you running Ora10g 10.1? this matches bug #3467567
    Check Metalink... if running on Ora10g 10.1 Oracle support may recommend to upgrade to Ora10g R2 - just my guess.
    Last edited by PAVB; 05-17-2010 at 10:57 AM. Reason: typo
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  6. #16
    Join Date
    Oct 2008
    Location
    Chandigarh, India
    Posts
    322
    Quote Originally Posted by PAVB View Post
    Now that we can see... we can help better.
    Are you running Ora10g 10.1? this matches bug #3467567
    Check Metalink... if running on Ora10g 10.1 Oracle support may recommend to upgrade to Ora10g R2 - just my guess.

    Yes, it is 10g R1. I will check metalink.


    Though, I forgot to thank you. Thanks for giving me this Bug ID.
    Last edited by mahajanakhil198; 05-17-2010 at 12:32 PM.
    lucky

  7. #17
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Quote Originally Posted by mahajanakhil198 View Post
    Yes, it is 10g R1. I will check metalink.


    Though, I forgot to thank you. Thanks for giving me this Bug ID.
    Glad to help.
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width