Oracle Database Cannot Open
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Oracle Database Cannot Open

  1. #1
    Join Date
    Apr 2010
    Posts
    2

    Oracle Database Cannot Open

    I have Oracle Real Application Cluster (RAC) Database 10g installed on Windows 2003 Server

    Database can be in mount state using RMAN
    However, Alter database open; gives an error

    RMAN-03002: failure of alter db command at 04/07/2010 10:06:53
    ORA-01113: file 1 needs media recovery
    ORA-01110: data file 1: 'N:\ORACLE\DEV\DB\APPS_ST\DATA\SYSTEM01.DBF'

    Then, tried restoring data from previous backup taken using RMAN.
    RESTORE DATABASE;
    The RMAN freezes, however after few hours the Alert log file shows that RMAN has restored all the 44 datafiles.

    Then tried recovery of data using RMAN
    RECOVER DATABASE; which too failed with the following error:
    ORA-00283: recovery session canceled due to errors
    RMAN-11003: failure during parse/execution of SQL statement: alter database recover if needed datafile 1
    ORA-00283: recovery session canceled due to errors
    ORA-00314: log 2 of thread 1, expected sequence# 289 doesn't match 0
    ORA-00312: online log 2 thread 1: 'N:\ORACLE\DEV\DB\APPS_ST\DATA\LOG02B.DBF'
    ORA-00314: log 2 of thread 1, expected sequence# 289 doesn't match 0
    ORA-00312: online log 2 thread 1: 'N:\ORACLE\DEV\DB\APPS_ST\DATA\LOG02A.DBF'

    Could anyone please help me out with this Issue

  2. #2
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Looks to me online logs are not in sync with restored datafiles
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  3. #3
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    what did you do to get to this situation?

  4. #4
    Join Date
    May 2002
    Posts
    2,645
    How many other forums are you spamming with this question?

  5. #5
    Join Date
    Apr 2010
    Posts
    2
    @ Stecal
    I am trying to get information from as many sources as possible because i need to get the problem solved urgently. So i am not spamming, but trying to get information

    This is a test database, so i was testing on it. I some how went for change database incarnation key. I think this might have caused the problem.

    I have tried with the following command
    SQL> CONN / AS SYSDBA
    SQL> RECOVER DATABASE USING BACKUP CONTROLFILE UNTIL CANCEL ;

    I was first asked about the following archive log file. So, i gave its location as:
    N:\oracle\DEV\db\apps_st\data\Archives\DEVDFA6E9F5_00289_0673919223.001
    Then, in a few minutes i was asked about the following archive log file:
    N:\oracle\DEV\db\apps_st\data\Archives\DEVDFA6E9F5_00105_0673919223.002
    After entering this file location, SQLPLUS got hanged. I waited for an hour but no response.

    This happened with RMAN also earlier. The RMAN gets hanged while restore and recovery.
    Why does the SQLPLUS or RMAN hang.

    I am thinking of restoring the database with image copy (cold backup) that i had taken before this problem raised.

    What could be the steps that i can follow to restore the cold backup keeping in mind that i have Oracle RAC 10 g with 2 instances on Windows 2003 server and running with Oracle Apps R12?

    Detailed steps would be appreciated.

    As it is test system, I dont care if i loose data, i just need to open the database so that i can carry on with testing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width