DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2009

    oracle hangs during install, after config assistants ...

    Hi All,

    i'm installing Oracle 10g (10.2.0) on opensolaris..

    i followed the instructions listed on this web page,

    as well as those listed in the Oracle's installation guide.

    i chose basic install, and all seemed to go well, and i got
    to the window that for that the Network/Database/iSQLPlus
    configuration assistants.

    all the configs ran to completion, and the last lines listed
    in the install log was:

    > INFO: Configuration assistant «Oracle Database Configuration Assistant» succeeded
    > INFO: Command = /opt/oracle/dwfms.product/10.2.0/db_1/bin/isqlplusctl start
    > iSQL*Plus
    > Copyright (c) 2003, 2005, Oracle. All rights reserved.
    > Starting iSQL*Plus …
    > iSQL*Plus started.
    > INFO: Configuration assistant «iSQL*Plus Configuration Assistant» succeeded
    > INFO: All the tools have been executed Successfully

    there are no more entries after this.
    ps(1) shows the following Oracle processes running:

    > odba 7621 1 0 16:36:23 ? 0:00 oracledwfms (LOCAL=NO)
    > odba 4908 1 0 14:43:18 ? 0:00 /opt/oracle/dwfms.product/10.2.0/db_1/bin/tnslsnr LISTENER -inherit
    > odba 5969 1 0 14:49:50 pts/7 0:10 /opt/oracle/dwfms.product/10.2.0/db_1/jdk/bin/java -Djava.awt.headless=true -Do
    > odba 7681 6458 0 16:41:54 pts/2 0:00 grep oracle
    > odba 5330 5325 0 14:45:03 pts/7 0:37 /opt/oracle/dwfms.product/10.2.0/db_1/jdk/bin/java -server -Xmx256M -XX:MaxPerm
    > odba 5325 1 0 14:45:02 pts/7 0:00 /opt/oracle/dwfms.product/10.2.0/db_1/perl/bin/perl /opt/oracle/dwfms.product/1
    > odba 5350 1 0 14:45:07 ? 0:01 oracledwfms (LOCAL=NO)
    > odba 5352 1 0 14:45:08 ? 0:01 oracledwfms (LOCAL=NO)
    > odba 5354 1 0 14:45:08 ? 0:02 oracledwfms (LOCAL=NO)
    > odba 7288 1 0 16:16:53 ? 0:00 oracledwfms (LOCAL=NO)
    > odba 5801 5325 0 14:46:34 pts/7 0:04 /opt/oracle/dwfms.product/10.2.0/db_1/bin/emagent
    > odba 5815 1 0 14:46:35 ? 0:02 oracledwfms (LOCAL=NO)
    > odba 5817 1 0 14:46:35 ? 0:01 oracledwfms (LOCAL=NO)

    has anybody encountered this?

    is there something else i need to do, to get the runInstaller
    to run to full completion?

    what other tasks is involved after the Config Assistant
    phase ? Can i run these manually ?

    Oracle admin guides mentioned this directory at different
    places: /var/opt/oracle .

    this is not present on my system. is this due to the incomplete
    install ?

    Thanks Very Much again,

  2. #2
    Join Date
    Jul 2002
    Lake Worth, FL

    Cool All clear.

    Seems you are ok:

    INFO: All the tools have been executed Successfully
    "The person who says it cannot be done should not interrupt the person doing it." --Chinese Proverb

  3. #3
    Join Date
    Sep 2009

    oracle now starts after reboot ... after ...

    Thanks LKBrwn_DBA,

    for the assurance :-)

    i wasn't able to get oracle to start after a reboot.

    1. after reading the scripts, found that dbstart had
    hardcoded a path variable:


    2. noticed that /opt/var/oracle/oratab was not

    executed the $ORACLE_HOME/root.sh

    edited the oratab file, to change the "N" at the
    end of the line, to "Y".

    dbstart checks for lines with "Y" for databases
    to start.

    3. when running dbstart on the command line, the
    system complained that oracle did not permissions
    to start the processes.

    saw that the oracle directories were owned by
    me. suspect that because i killed runInstaller
    after it hang'ed, it didn't get around to changing the
    ownerships ..

    cd(1) to $ORACLE_HOME/../..

    which for me is the directory 10.2.0 (under product).

    chown -R oracle:dba .

    set the directories for oracle accesses.

    4. this time, at the command line, dbstart ran okay,
    but ps(1) did not show the listener processes.

    network/logs/listener.log shows that the listener
    process was still having permission problems.

    didn't say what resources were involved ...

    after running truss over the process, saw that the
    listener process was getting EPERMs when accessing

    the dir belonged to root, and the 2 files created in
    that dir belonged to me.

    suspect that these were created when i ran the scripts
    under different user accounts, when i was debugging the

    shutdown the oracle related processes, removed
    the /var/tmp/.oracle

    5. rebooted the system, now the processes are started.

    not sure if all the required processes are there,
    don't know enough about oracle arch ...

    going through the oracle admin guides and concept
    doc now ..

    hopefully, somebody else who is installing oracle on
    opensolaris (2009.06), will find this info of some help.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.