Dbconsole Startup Fails
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Dbconsole Startup Fails

Hybrid View

  1. #1
    Join Date
    Jul 2009
    Posts
    6

    Dbconsole Startup Fails

    Os:AIX
    DB Version:10.2.0.4


    Hi,

    I have recently upgraded a 9.2.0.7 database to 10.2.4. and OEM was configured manullay using emca. The installation went without any problem.
    Now I am facing a problem with starting up DBconsole although the agent starts up successfully . Below are some evidences and logs.

    Oracle Enterprise Manager 10g Database Control Release 10.2.0.4.0
    Copyright (c) 1996, 2007 Oracle Corporation. All rights reserved.
    https://sapm30:1158/em/console/aboutApplication
    Starting Oracle Enterprise Manager 10g Database Control ............................................................................................. failed.
    ------------------------------------------------------------------
    Logs are generated in directory /oracle/M30/102_64/sapm30_M30/sysman/log


    Now when emdctl.trc is viewed the entire contains the two lines given above multiple times.
    It does not contain anything different from the two lines given below which appears multiple times.

    [LOG]

    2009-07-09 13:25:15 Thread-1 WARN http: snmehl_connect: connect failed to (sapm30:1158): A remote host refused an attempted connect operation. (error = 79)
    2009-07-09 13:35:07 Thread-1 WARN http: snmehl_connect: connect failed to (sapm30:3938): A remote host refused an attempted connect operation. (error = 79)
    2009-07-09 13:35:25 Thread-1 WARN http: snmehl_connect: connect failed to (sapm30:3938): A remote host refused an attempted connect operation. (error = 79)

    [/LOG]
    ================================================================

    Please note that the port 1158 and 3938 are active and does have entry in /etc/services file.

    Contents of emdb.nohup

    [LOG]

    ----- Thu Jul 9 13:15:09 2009::Property 'agentTZRegion' is missing from /oracle/M30/102_64/sapm30_M30/sysman/config/emd.properties. This is normal when th
    e agent is started for the very first time.Updating it... -----
    ----- Thu Jul 9 13:15:09 2009::/oracle/M30/102_64/sapm30_M30/sysman/config/emd.properties copied to /oracle/M30/102_64/sapm30_M30/sysman/config/emd.properti
    es.2009-07-09-13-15-09 while updating the property 'agentTZRegion' -----
    ----- Thu Jul 9 13:15:10 2009::An agentTZregion of 'GMT' is installed in /oracle/M30/102_64/sapm30_M30/sysman/config/emd.properties. -----
    ----- Thu Jul 9 13:15:10 2009::Agent Launched with PID 1777760 at time Thu Jul 9 13:15:10 2009 -----
    (pid=1777760): starting emagent version 10.1.0.6.0
    OMS does not understand the timezone region of the agent. Either start the OMS using the extended list of time zones supported by the database or pick a valu
    e of time zone from /oracle/M30/102_64/sysman/admin/nsupportedtzs.lst , update the property 'agentTZRegion' in the file /oracle/M30/102_64/sapm30_M30/sysman/
    config/emd.properties and restart the agent.A value which is around an offset of +00:00 from GMT should be picked.
    (pid=1777760): emagent now exiting abnormally - initialization failure. Consult '.trc' and '.log' files.
    ----- Thu Jul 9 13:16:11 2009::EMAgent exited at Thu Jul 9 13:16:11 2009 with return value 55. -----
    ----- Thu Jul 9 13:16:11 2009::EMAgent has exited due to initialization failure. -----
    ----- Thu Jul 9 13:16:11 2009::Stopping other components. -----
    ----- Thu Jul 9 13:16:11 2009::EMWD Stopping DBConsole. -----
    --- DBConsole internal stop. No OC4J admin passwd hence hard stop. ---

    [/LOG]
    ==============================================================


    Please note that agentTZRegion in /oracle/M30/102_64/sapm30_M30/sysman/config/emd.properties is GMT which is supported in /oracle/M30/102_64/sysman/admin/nsupportedtzs.lst and env settings for TZ is also the same.

    Moreover when I try to start the agent it starts up successfully

    sapm30ram30 39> emctl start agent
    Oracle Enterprise Manager 10g Database Control Release 10.2.0.4.0
    Copyright (c) 1996, 2007 Oracle Corporation. All rights reserved.
    Starting agent ... started.

    But still Dbconsole fails to start .

    TZ=GMT0
    The above timezone is supported in /oracle/M30/102_64/sysman/admin/nsupportedtzs.lst and present in /oracle/M30/102_64/sapm30_M30/sysman/config/emd.properties as the value of agentTZRegion.


    Please advice what needs to be done to resolve this.


    Thanks and Regards
    Dbcop

  2. #2
    Join Date
    Sep 2000
    Location
    Sao Paulo,SP,Brazil, Earth, Milky Way
    Posts
    350
    I had a similar issue last year : in a Solaris 9 box, 9.2.0.7 EE was upgraded to 10.2.0.4 , TZ was set in SO to Brazil/East (a valid value), identical value was in the dbconsole file, but dbconsole startup was always complaining about TZ. Sr was open, all the available TZ patches was applied, but no avail, only the work-around of changing TZ value in SO temporary before the start (and in dbconsole properties file) worked... Dunno if this is your case, it was my experience....

    Regards,

    Chiappa

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width