Error in install-10G
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: Error in install-10G

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Posts
    231

    Error in install-10G

    Hi all,

    Am using RHEL-5 (2.6.18-8.el5).I have set all pre-Installation settings for oracle 10.2; when I gave ./runInstaller

    Code:
    Starting Oracle Universal Installer...
    
    Checking installer requirements...
    
    Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
                                          Passed
    
    
    All installer requirements met.
    
    Preparing to launch Oracle Universal Installer from /tmp/OraInstall2009-06-29_11-05-37AM. Please wait ...[oracle@miet database]$ Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    
    Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
            at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
            at sun.awt.X11GraphicsEnvironment.(Unknown Source)
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Unknown Source)
            at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(Unknown Source)
            at java.awt.Window.init(Unknown Source)
            at java.awt.Window.(Unknown Source)
            at java.awt.Frame.(Unknown Source)
            at oracle.ewt.popup.PopupFrame.(Unknown Source)
            at oracle.ewt.lwAWT.BufferedFrame.(Unknown Source)
            at oracle.sysman.oio.oioc.OiocOneClickInstaller.(OiocOneClickInstaller.java:378)
            at oracle.sysman.oio.oioc.OiocOneClickInstaller.main(OiocOneClickInstaller.java:2091)
    received this error message. How to solve this problem .

    Thanks in adv.

  2. #2
    Join Date
    Mar 2006
    Location
    Charlotte, NC
    Posts
    865
    set DISPLAY variable value correctly and check it before running installer.

    Thanks,
    Vijay Tummala

    Try hard to get what you like OR you will be forced to like what you get.

  3. #3
    Join Date
    Jan 2007
    Posts
    231
    I have given as
    DISPLAY=miet:0.0; export DISPLAY
    It doesn't works changed to miet.com then to miet.miet.com nothing works


    Code:
    Checking installer requirements...
    
    Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
                                          Passed
    
    
    All installer requirements met.
    
    Preparing to launch Oracle Universal Installer from /tmp/OraInstall2009-06-29_11-35-06AM. Please wait ...[oracle@miet database]$ _X11TransSocketINETConnect() can't get address for miet:6000: Temporary failure in name resolution
    Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using 'miet.com:0.0' as the value of the DISPLAY variable.
            at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
            at sun.awt.X11GraphicsEnvironment.(Unknown Source)
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Unknown Source)
            at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(Unknown Source)
            at java.awt.Window.init(Unknown Source)
            at java.awt.Window.(Unknown Source)
            at java.awt.Frame.(Unknown Source)
            at oracle.ewt.popup.PopupFrame.(Unknown Source)
            at oracle.ewt.lwAWT.BufferedFrame.(Unknown Source)
            at oracle.sysman.oio.oioc.OiocOneClickInstaller.(OiocOneClickInstaller.java:378)
            at oracle.sysman.oio.oioc.OiocOneClickInstaller.main(OiocOneClickInstaller.java:2091)
    
    [oracle@miet opt]$ uname -a
    Linux miet.miet.com 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007 i686 i686 i386 GNU/Linux

  4. #4
    Join Date
    Mar 2006
    Location
    Charlotte, NC
    Posts
    865
    please try IP address instead of host name.

    Thanks,
    Vijay Tummala

    Try hard to get what you like OR you will be forced to like what you get.

  5. #5
    Join Date
    Jan 2007
    Posts
    231
    that too doesn't helps.
    Any other way.


    thanks for ur help...

  6. #6
    Join Date
    Mar 2006
    Location
    Charlotte, NC
    Posts
    865
    how are you connected? are you physically connected to the server or connected remotely?

    If you are connected remotely just type "xhost +" on the client machine.

    If you are physically connected then type DISPLAY=":0.0" export DISPLAY

    Thanks,
    Vijay Tummala

    Try hard to get what you like OR you will be forced to like what you get.

  7. #7
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    do you actually have an xserver running? are you on the console of the machine or running through an ssh client

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width