not able to map numerical identifiers to table and column names
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: not able to map numerical identifiers to table and column names

  1. #1
    Join Date
    Oct 2008
    Location
    Chandigarh, India
    Posts
    322

    not able to map numerical identifiers to table and column names

    I tried to mine the redo logs. But the following output shows numerical identifiers for table and column names. I extracted the dictionary using dbms_logmnr_d.build procedure.

    here is the output:
    SQL> create table log_tab as select * from v$logmnr_contents;

    Table created.

    SQL> select sql_redo from log_tab where operation='INSERT';

    SQL_REDO
    -----------------------------------------------------------------------------------------
    insert into "SYS"."OBJ$"("OBJ#","DATAOBJ#","OWNER#","NAME","NAMESPACE","SUBNAME","TYPE#",
    insert into "SYS"."ING"("A") values ('1');
    insert into "SYS"."ING"("A") values ('2');
    insert into "SYS"."ING"("A") values ('2');
    lucky

  2. #2
    Join Date
    Oct 2008
    Location
    Chandigarh, India
    Posts
    322
    actually right results are being displayed. i didnt notice the other rows after fisrt row. I think first row is a result of some recursive statement..thet other rows correctly describe what i wanted to retrieve..moreover, for appropriate display of results using lominer utility, I should have specified segment's name on which I wanted to track DML by users
    lucky

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width