11g-Connect from SQLPLUS but not TOAD
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: 11g-Connect from SQLPLUS but not TOAD

Hybrid View

  1. #1
    Join Date
    Sep 2000
    Location
    VA
    Posts
    343

    11g-Connect from SQLPLUS but not TOAD

    All,

    I am able to connect to my 11g database remotely via SQLPLUS but not through TOAD. I get 'invalid username/password' error. I have tried with different password cases, I am able to connect to other 11g databases, but not this particular one. My TOAD version is 9.0. Any ideas ?

    Thanks.

  2. #2
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    You are probably pointing to the wrong database, not your fault. Toad has the ability to work with multiple TNSNAMES files which sometimes might be a nightmare.

    Look at file CONNECTIONS.INI
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  3. #3
    Join Date
    Jul 2002
    Location
    Lake Worth, FL
    Posts
    1,460

    Talking Sec_case_sensitive_logon

    If you have set the SEC_CASE_SENSITIVE_LOGON parameter to true, then the database expects "case sensitive" passwords. TOAD somehow seems to convert the passwords to uppercase before logon.

    Workarounds:

    1) Set your password in the database to UPPER case -- or --
    2) Set SEC_CASE_SENSITIVE_LOGON parameter to false.
    "The person who says it cannot be done should not interrupt the person doing it." --Chinese Proverb

  4. #4
    Join Date
    Sep 2000
    Location
    VA
    Posts
    343
    Quote Originally Posted by LKBrwn_DBA
    If you have set the SEC_CASE_SENSITIVE_LOGON parameter to true, then the database expects "case sensitive" passwords. TOAD somehow seems to convert the passwords to uppercase before logon.

    Workarounds:

    1) Set your password in the database to UPPER case -- or --
    2) Set SEC_CASE_SENSITIVE_LOGON parameter to false.
    Thanks LKBrwn_DBA. Setting the password to uppercase in the database helped me login via TOAD.

  5. #5
    Join Date
    Mar 2009
    Posts
    1

    Case sensitivity

    the situation could be the same with sqlplus as well. It all depends on how the sqlcase variable has been set. MIXED, UPPER or LOWER. TOAD seems to set to UPPER all the passwords before sending them to the db server. SQL developer though does not seem to alter their case.

  6. #6
    Join Date
    Jun 2010
    Posts
    1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width