problem with sys log in
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: problem with sys log in

  1. #1
    Join Date
    Aug 2008
    Posts
    118

    problem with sys log in

    hi all,

    I am trying to connect Oracle10 database but when i am trying to connect with sys log init gives me problem for insufficient previleges.

    sqlplus /nolog

    SQL*Plus: Release 10.2.0.1.0 - Production on Wed Oct 8 08:53:31 2008

    Copyright (c) 1982, 2005, Oracle. All rights reserved.

    SQL> conn as sysdba
    Enter user-name: sys
    Enter password:
    ERROR:
    ORA-01031: insufficient privileges


    what should i do?

    please guide!!

    thanks
    Pat

  2. #2
    Join Date
    Mar 2006
    Location
    Charlotte, NC
    Posts
    865
    what is your environment? windows or unix ?

    Thanks,
    Vijay Tummala

    Try hard to get what you like OR you will be forced to like what you get.

  3. #3
    Join Date
    Aug 2008
    Posts
    118
    it's on unix(sun solaris)

  4. #4
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Shall we understand you were able to connect that way in the past?
    Do you have remote authentication enabled?
    Are you using the oracle account to log into the Unix box?
    Have you set your environmental variables properly?
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  5. #5
    Join Date
    Aug 2008
    Posts
    118
    yes they are all fine and the instnace comes back perfectly fine. but when i try to connect with sys id i get the errot ther previleges...

  6. #6
    Join Date
    Mar 2006
    Location
    Charlotte, NC
    Posts
    865
    are you using oracle id to connect unix box?

    Thanks,
    Vijay Tummala

    Try hard to get what you like OR you will be forced to like what you get.

  7. #7
    Join Date
    Aug 2008
    Posts
    118
    no

  8. #8
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    you need to use an Id thats in the correct group on the server (usually dba)

  9. #9
    Join Date
    Aug 2008
    Posts
    118
    I am connecting with unix id which is in dba group on the server!!

  10. #10
    Join Date
    Oct 2008
    Posts
    6

    Post try this

    Please try:

    sqlplus / as sysdba


    If that doesn't work (it should on unix, if your userid is a member of the 'dba' group) please let us know the setting of remote_login_passwordfile

    G Luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width