URGENT HELP please
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: URGENT HELP please

  1. #1
    Join Date
    Jan 2001
    Posts
    318
    We cannot connect to schema manager using system/manager anymore it says that table or view does not exists .. I can connect to it using worksheet.
    when I look at dba_tablespaces it shows default tablespace for SYSTEM as USER. Is it correct ??? Should that be SYSTEM.
    I can connect to it using sys/password.

    Thanks
    Sonali

  2. #2
    Join Date
    Jun 2000
    Posts
    417
    Default tablespace user for SYSTEM is ok as long as it exists. In fact it's probably better than SYSTEM so that tablespace doesn't get cluttered and is used for objects owned by SYS.

    What is giving the "table or view does not exist" error? Can you connect as system/manager through other utilities like sql*plus?

  3. #3
    Join Date
    Jan 2001
    Posts
    318
    I don't know what has happened but SYSTEM user and all other users had lost priviledges to user tables and v$objects. After I ran catalog.sql script everthing seems to be fine now.
    I cnhanged sys password before that could that cause this ??
    One more thing in catalog.sql script...
    create or replace view v_$dlm_latch as select * from v$dlm_latch;
    drop public synonym v$dlm_latch;
    create public synonym v$dlm_latch for v_$dlm_latch;
    grant select on v_$dlm_latch to select_catalog_role;

    I had to change 'select_catalog_role' with 'dba' to get everything back to working. Why 'select_catalog_role' did not work ?

    How come I was able to view all these views and connect to schema manager using sys access ? Why not system..
    I even tries grant execute and select on these catalog objects to system. It did not work.

    Yes I was able to connect to that database using worksheet.

    Thanks
    Sonali

  4. #4
    Join Date
    Jun 2000
    Posts
    417
    possibly something happened to your select_catalog_role. sys owns the objects so he doesn't need the role to be able to see them. what error did it give that let you know that select_catalog_role wasn't working?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width