ORA-09817: Write to audit file failed.
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: ORA-09817: Write to audit file failed.

  1. #1
    Join Date
    Apr 2008
    Posts
    22

    ORA-09817: Write to audit file failed.

    Hi,

    I have an exp running on a schedule daily as a method to backup our database. Recently I started getting this error:

    EXP-00008: ORACLE error 9817 encountered
    ORA-09817: Write to audit file failed.
    EXP-00000: Export terminated unsuccessfully

    I have checked permissions to the audit log file and everything is ok. I have also checked disk space and there is tons. Any idea what is causing this problem?

    SYSTEM: Windows 2003 Std. Ed. Oracle 10g R2

    Thanx
    D

  2. #2
    Join Date
    Jul 2002
    Location
    Lake Worth, FL
    Posts
    1,480

    Thumbs down WinDoze?

    Yes, this is your problem: SYSTEM: WinDoze.

    PS: Export is not a good method to backup your database.

    Check the value for: AUDIT_FILE_DEST parameter and the value of the instance parameter AUDIT_SYS_OPERATIONS.

    Re-check if you have privileges to write on the AUDIT_FILE_DEST path or the path is full.
    Last edited by LKBrwn_DBA; 08-19-2008 at 03:17 PM.
    "The person who says it cannot be done should not interrupt the person doing it." --Chinese Proverb

  3. #3
    Join Date
    Apr 2008
    Posts
    22
    hehehehe... But WinDoze works eh... and yes, I know exp is not a good way to back up my database, but it works for us - for now...

    show parameter AUDIT_FILE_DEST:

    audit_file_dest string D:\ORACLE\PRODUCT\10.2.0\ADMIN\SPFDB\ADUMP

    show parameter AUDIT_SYS_OPERATIONS:

    audit_sys_operations boolean TRUE

    I have checked permissions and it is correct. Further I am administrator on the server so have complete permissions.

    Any other ideas?

  4. #4
    Join Date
    Nov 2001
    Posts
    335
    Post your export script please
    One, who thinks that the other one who thinks that know and does not know, does not know either!

  5. #5
    Join Date
    Apr 2008
    Posts
    22
    exp '/@SPFDB as sysdba' file=D:\Backup\SPFDB.dmp log=D:\Backup\SPFDB.log full=yes statistics=none

  6. #6
    Join Date
    Dec 2007
    Posts
    82
    check the file system having enough space to have file size growing.
    Cheers...
    /MR

  7. #7
    Join Date
    Jul 2002
    Location
    Lake Worth, FL
    Posts
    1,480

    Talking exp /@SPFDB

    Try this:
    Code:
    exp /@SPFDB file=D:\Backup\SPFDB.dmp log=D:\Backup\SPFDB.log full=yes statistics=none
    "The person who says it cannot be done should not interrupt the person doing it." --Chinese Proverb

  8. #8
    Join Date
    Apr 2008
    Posts
    22
    There is enough space on the disk 40.1GB.

    If I remove the 'as sysdba' it then askes for a username and password when executing the script.

  9. #9
    Join Date
    Nov 2001
    Posts
    335
    put another valid userid and password instead of sysdba. sysdba connections are monitored and traces stored on the disk where you lacking free space

    exp system/manager@db .......
    Last edited by BV1963; 08-20-2008 at 12:48 PM.
    One, who thinks that the other one who thinks that know and does not know, does not know either!

  10. #10
    Join Date
    Apr 2008
    Posts
    22
    if I do an exp using a username and password it works just fine. So, yes it obviously has something to do with Audit. Besides permissions and space, what else can I look for. ON the web, I have only found articles regarding permissions and space...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width