Problem with listener (ORA-12514) after shut down and re-start
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Problem with listener (ORA-12514) after shut down and re-start

Hybrid View

  1. #1
    Join Date
    May 2008
    Posts
    1

    Problem with listener (ORA-12514) after shut down and re-start

    Hi,

    I have installed Oracle XE version 10.2.0 in Windows XP professional.

    After installing the database, in the listener I could see the service XE registered with it.

    "Service "XE" has 1 instance(s).
    Instance "XE", status READY, has 1 handler(s) for this service...
    Service "XEXDB" has 1 instance(s).
    Instance "XE", status READY, has 1 handler(s) for this service...
    Service "XE_XPT" has 1 instance(s).
    Instance "XE", status READY, has 1 handler(s) for this service..."

    But once I shutdown the window machine and restart it, the problem status.

    When I try to connect the system, ORA-12514 error message is thrown.
    SQL> connect username/password@XE
    ERROR:
    ORA-12514: TNS:listener does not currently know of service requested in connect
    descriptor

    (a) The database service (OracleServiceXE) has started automatically and is running.
    (b) The listener.ora [C:\oraclexe\app\oracle\product\10.2.0\server\NETWORK\ADMIN] has the correct setup.
    ============
    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = C:\oraclexe\app\oracle\product\10.2.0\server)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (SID_NAME = CLRExtProc)
    (ORACLE_HOME = C:\oraclexe\app\oracle\product\10.2.0\server)
    (PROGRAM = extproc)
    )
    )

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
    (ADDRESS = (PROTOCOL = TCP)(HOST = HCL)(PORT = 1521))
    )
    )

    DEFAULT_SERVICE_LISTENER = (XE)
    ============

    (b) If I check the listener status, XE service is not registered.

    =============
    LSNRCTL> status
    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for 32-bit Windows: Version 10.2.0.1.0 - Beta
    Start Date 27-APR-2008 18:34:23
    Uptime 0 days 0 hr. 12 min. 22 sec
    Trace Level off
    Security ON: Local OS Authentication
    SNMP OFF
    Default Service XE
    Listener Parameter File C:\oraclexe\app\oracle\product\10.2.0\server\network\a
    dmin\listener.ora
    Listener Log File C:\oraclexe\app\oracle\product\10.2.0\server\network\l
    og\listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=HCL)(PORT=1521)))
    Services Summary...
    Service "CLRExtProc" has 1 instance(s).
    Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    The command completed successfully
    =============

    The strange thing is the service XE was registered before shuting down the system.

    Other point to be noted is, once the error message comes, if I un-install Orace XE and re-install it, then while checking the listener status, service XE is registered. Again, after shut down and re-start, it is gone.

    Can somebody let me know where the problem lies.

    Thanks.

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    is the database actually running

  3. #3
    Join Date
    May 2008
    Posts
    1
    Yes, the database is running.

    PS: To double check, I even started the database manually. It was already running.

    C:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleMTSRecoveryServ
    ice
    The requested service has already been started.

    More help is available by typing NET HELPMSG 2182.


    C:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleXETNSListener
    The requested service has already been started.

    More help is available by typing NET HELPMSG 2182.


    C:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleServiceXE
    The requested service has already been started.

    More help is available by typing NET HELPMSG 2182.

  4. #4
    Join Date
    Jul 2002
    Location
    Lake Worth, FL
    Posts
    1,471

    Talking

    What about the tnsnames.ora file?

    Check it out!
    "The person who says it cannot be done should not interrupt the person doing it." --Chinese Proverb

  5. #5
    Join Date
    Feb 2010
    Posts
    1

    I also faced the same issue...

    I also faced the same issue two days back. I struggled for one whole day.. many times a restarted my PC, disabled firewall, started Oracle services manually but no luck...

    After one day.. i again restarted the system, turned of my pc's firewall protection, closed some processes from task manager like blackice, blackiced, msnmsgr etc, started the OracleServiceXE and OracleXETNSListener services manually since they were not getting started automaticallly and then my problem was solved.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width