Dear DBA's,

My system is an Oracle 10.2.0.3 2-node RAC on AIX 5.3, with ASM & has been running for over a year now without any major hitches. Recently, i tried using dbca to create a new database, but was getting the following error message:

DBCA could not startup the ASM instance configured
on this node. To proceed with ASM diskgroup
management you need the ASM instance to be up
and running. Do you want to recreate the ASM
instance on this node?

Yes/No

Actually, when i run the crs_stat -t command from the $ORACLE_CRS_HOME/bin, it tells me all my resources are online in all 2 cluster nodes. So i decided to query the ASM instance, which gave me the following errors:

SQL> select instance_name,status from gv$instance;
select instance_name,status from gv$instance
*
ERROR at line 1:
ORA-00604: error occurred at recursive SQL level 1
ORA-04031: unable to allocate 4040 bytes of shared memory ("shared
pool","select ks.inst_id,ksuxsins,k...","Typecheck","seg:kggfaAllocSeg")

I think this is telling me to increase the shared pool memory of the ASM instance. How do i do this when my ASM uses ASMM, & the shared pool parameter is not defined in the automatically generated initASM.ora file?

Your help will be highly appreciated...

Divine