emctl program in $ORACLE_HOME/bin is missing
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: emctl program in $ORACLE_HOME/bin is missing

  1. #1
    Join Date
    Jan 2006
    Posts
    39

    emctl program in $ORACLE_HOME/bin is missing

    I have Oracle 10g release 2 on Solaris 10 server. I have found that, in $ORACLE_HOME/bin/ directory, emctl program contains 0 byte. When I typed
    >emctl start dbconsole. UNIX system didn't respond.

    Compared with other Oracle 10g on other UNIX server, I have found that emctl program contains from 12410 to 12425 byte. Does this mean emctl program on this server has been deleted? This emctl program used to work. I don't know how could this happen. Please advise me how to reinstall this component back to bin folder and make it work.

  2. #2
    Join Date
    Nov 2000
    Location
    Pittsburgh, PA
    Posts
    3,999
    Did someone accidentally overwrite the file? Try renaming the file and copy one over from an identical system. ie. same version of Oracle, patch level and os.
    this space intentionally left blank

  3. #3
    Join Date
    Jan 2006
    Posts
    39
    gandolf989:

    Thanks for your kind help. It works. I copied emctl from another Oracle 10g at the same version and modified ORACLE_HOME. it works fine now.
    Last edited by traveller; 04-07-2008 at 12:28 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width