TNS-12546: TNS: permission denied
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: TNS-12546: TNS: permission denied

Hybrid View

  1. #1
    Join Date
    Nov 2000
    Posts
    160

    TNS-12546: TNS: permission denied

    Dear all,

    I need help on this listener error. We have a 10g cluster database with two nodes on Windows servers. Lately, we started to run into "TNS-12546: TNS: permission denied" error randomly throughout the day. I checked the listener.log and found these errors:

    TNS-12520: TNS:listener could not find available handler for requested type of server
    21-MAR-2008 00:02:09 * service_update * instance1 * 0
    21-MAR-2008 00:02:09 * 12546
    TNS-12546: TNS: permission denied
    TNS-12560: TNS: protocol adapter error
    TNS-00516: Permission denied

    No longer listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=hostname.com)(PORT=1521)))
    Listener completed notification to CRS on stop

    I also tried to connect through the command line using @alias, and got "ORA-12541: TNS:no listener" error. However, if I tried to connect again in next few second, I was able to connect without any error. I am not sure what causes it. I can understand that we were truly have permission problem if these errors occur every time when we connect, but they don't; these happened randomly throughout the day.

    I checked with our network folks, but there wasn't anything done lately. Any help is very help!


    Thanks in advance,
    Unna

  2. #2
    Join Date
    Nov 2000
    Posts
    160
    I found out these errors were caused by something, like some kind of scheduled job, that stop and start the listener every minute through out the day. I was able to put LOCAL_OS_AUTHENTICATION on listener.ora to prevent that job from stopping and starting listener. Instead of getting no listener error, I got "The listener has not recognized the password" error every minute.

    We have no luck on finding what cause it. I wonder if there is something in clusterware that checks the listener status? Help please!


    Thanks,
    Unna

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width