Problems to register a database in the recovery catalog Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Problems to register a database in the recovery catalog

  1. #1
    Join Date
    Mar 2008
    Santiago de Chile

    Problems to register a database in the recovery catalog

    I want to register a database in my recovery catalog, in which I have information about 10 databases with release The catalog's database is and the database that I want to register is also, when I try to register it, it happens the following:

    rman target sys/xxxxx@psp1 catalog rman/rman@catalogo

    Recovery Manager: Release - Production

    RMAN-06005: connected to target database: PSP1 (DBID=1959756135)
    RMAN-06008: connected to recovery catalog database

    RMAN> register database;

    RMAN-03022: compiling command: register
    RMAN-03023: executing command: register
    RMAN-08006: database registered in recovery catalog
    RMAN-03023: executing command: full resync
    RMAN-08002: starting full resync of recovery catalog
    RMAN-03026: error recovery releasing channel resources
    RMAN-00571: ===========================================================
    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
    RMAN-00571: ===========================================================
    RMAN-03008: error while performing automatic resync of recovery catalog
    RMAN-07004: unhandled exception during command execution on channel default
    RMAN-20036: invalid record order

    But when I connect to recovery catalog with the rman user, it says to me that the database is registered, however I can not backup this database using the recovery catalog:

    sqlplus rman/rman@catalogo

    SQL*Plus: Release - Production on Tue Mar 18 16:18:54 2008

    Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

    Connected to:
    Oracle9i Enterprise Edition Release - Production
    With the Partitioning, OLAP and Oracle Data Mining options
    JServer Release - Production

    SQL> select * from rc_database;

    ---------- ---------- ---------- -------- ----------------- ---------
    1041936 1041937 1959756135 PSP1 1 15-JAN-08

    Thanks a lot.
    Luis Flores Z.

  2. #2
    Join Date
    Jan 2001

    I am thinking this could be a bug or something
    Did you check metalink ?


  3. #3
    Join Date
    Mar 2008
    Santiago de Chile
    Thanks for your answer. I have already checked some articles of metalink, I have done different things, which haven't worked. I have also unregistered the database through dbms_rcvcat package and then I have tryied to register it again and the recovery catalog says to me the same error. I think it could be a bug because all others databases are and they have been registered without any problems.

  4. #4
    Join Date
    Nov 2000
    don't you have to be sysdba? try being on the server itself to register.
    Jeff Hunter
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width