dcsimg
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Insufficient Privileges.

  1. #1
    Join Date
    Nov 2007
    Location
    Douala, Cameroun.
    Posts
    77

    Insufficient Privileges.

    I have this pb on my oracle 9i database: It returns the ora-01301 error when I try to connect to it. I checked the remote_login_passwordfile parameter and it is set to true. I also tried and add the remote_os_authentication and set it to true but my system didn't recognize it.

    Here's the actual error message and the way I tried and connect:
    Microsoft Windows [version 5.2.3790]
    (C) Copyright 1985-2003 Microsoft Corp.

    C:\Documents and Settings\Ousmanou>set oracle_sid=prod

    C:\Documents and Settings\Ousmanou>sqlplus /nolog

    SQL*Plus: Release 9.2.0.1.0 - Production on Ve Dec 14 07:54:25 2007

    Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

    SQL> conn / as sysdba
    ERROR:
    ORA-01031: insufficient privileges


    SQL>

    I compared the sqlnet.ora of that installation with the sqlnet.ora of another installation where the conn / as sysdba works fine and below is the difference I noticed.

    The one working had the following lines:


    SQLNET.AUTHENTICATION_SERVICES= (NTS)

    # This file is actually generated by netca. But if customers choose to
    # install "Software Only", this file wont exist and without the native
    # authentication, they will not be able to connect to the database on NT.


    Indeed, while doing the first installation I had chosen the "Software only" option. I made a copy-paste of that line hoping that it might work... it didn't. Later on, using net configuration assistant, after deleting the "corrupted" sqlnet.ora file, I configured the naming methods resolution and the new sqlnet.ora that was generated looked like the following :

    # SQLNET.ORA Network Configuration File: D:\oracle\ora92\network\admin\sqlnet.ora
    # Generated by Oracle configuration tools.

    NAMES.DEFAULT_DOMAIN = afogic.local

    SQLNET.AUTHENTICATION_SERVICES= (NTS)

    NAMES.DIRECTORY_PATH= (TNSNAMES, HOSTNAME, ONAMES)

    But when I tried to connect it yielded the same error message. Any tips?

    P.S. I should mention that when I connect using the following method "sys/prod@prod as sysdba" it works. And I run my database on Windows.

  2. #2
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,555
    The Windows account you are using probably wasn't added to ORA_DBA group.
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  3. #3
    Join Date
    Nov 2007
    Location
    Douala, Cameroun.
    Posts
    77
    Let me check that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width