ERROR: Ora-1031. Can't Connect.
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: ERROR: Ora-1031. Can't Connect.

  1. #1
    Join Date
    Oct 2006
    Posts
    175

    ERROR: Ora-1031. Can't Connect.

    Hi all,
    I'm caught up in a strange situation here. I have had this test DB server in my laptop since one year. But I didn't start it since 3 months as another test server was available in my workplace.
    Now when I try to connect to it using Sql*Plus and run it again, it keeps saying:

    ERROR:
    ORA-1031: insufficient privileges

    I am on Win2K XP Pro, Oracle 9iR2, Sqlplus

    tnsnames.ora entry
    GTDB=
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = GT-LAP)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = GTDB)
    )
    )

    Any advice or hints is highly appreciated.

    Thanks,

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    you username isnt in the ORA_DBA group

  3. #3
    Join Date
    Oct 2006
    Posts
    175
    Thanks Dave,
    I found my login was not included in the Ora_Dba group and also I was missing the pwdfile, which I've created now. I can connect to the instance now. However, it is still not allowing me to start the DB. Throws out same error message when I do Startup. Please advise.

    Thanking you once again,
    Last edited by gtcol; 10-09-2007 at 01:17 PM.

  4. #4
    Join Date
    Oct 2006
    Posts
    175
    Hi all,
    I am still waiting for your advice. I ain't still able to start my DB. Pleaseeeee advise.

    Thanks

  5. #5
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Set you ORACLE_HOME and ORACLE_SID, then
    sqlplus /nolog
    conn sys as sysdba
    startup force

    Please post whole session log.
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  6. #6
    Join Date
    Oct 2006
    Posts
    175
    Hi PAVB,
    I did set ORACLE_SID and ORACLE_HOME and connected to the instance. But still I can't start the DB.

    C:\>set oracle_sid=gtdb

    C:\>set oracle_home=e:\oracle

    C:\>sqlplus /nolog

    SQL*Plus: Release 9.2.0.1.0 - Production on Fri Oct 12 16:36:56 2007

    Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

    SQL> conn sys as sysdba;
    Enter password:
    Connected to an idle instance.
    SQL> startup force
    ORA-01031: insufficient privileges
    SQL>

    And also, it is not generating any UDUMP or BDUMP logs in its folders. What could be other possible reason for it to not allow me to start the DB?

    Thanks,

  7. #7
    Join Date
    Oct 2006
    Posts
    175
    Hi all,
    I started the DB with PFILE this time and it started without any problem. And then I recreated spfile and shutdown the DB. I again started the DB with spfile and it started the DB without any problem this time. So, it makes me think that my earlier spfile was corrupted.
    Thanks to all for your suggestions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width