connection problem to database 10g with BRIO client
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: connection problem to database 10g with BRIO client

  1. #1
    Join Date
    Oct 2005
    Posts
    90

    connection problem to database 10g with BRIO client

    Hi ,
    Application team is trying to connect through BRIO client and are unable to after migration to 10g, the following is the error they were getting when trying to connect through allication programme .Login credentials have read only privls.

    DBI connect('host=gvxxxx.xxxx.xx.com;port=1525;sid=xxxx','NPIread',...) failed: ORA-12505: TNS:listener could not resolve SID given in connect descriptor (DBD ERROR: OCIServerAttach) at /pcbsw/rose/web/cgi-bin/wwp/npi_findBOMrevs.pl line 47 Can't connect to Oracle database: ORA-12505: TNS:listener could not resolve SID given in connect descriptor (DBD ERROR: OCIServerAttach)
    which is fixed by As Oracle 10g identifies with "SERVICE_NAME", so he has to change in construct from "SID" to "SERVICE_NAME".

    For connecting through BRIO client these changes have been made.
    1 Create a new File DSN/System DSN using Microsoft ODBC for Oracle/Oracle ODBC for Oracle 10g drivers.
    a I old one could be connecting using SID keyword, It is better to create a new ODBC connection using SERVICE_NAME.
    2 BRIO client connects to database uses a plain 'ODBC' connection
    3 Oracle 10g identifies with "SERVICE_NAME", so change in construct from "SID" to "SERVICE_NAME" .

    everything has been done from 1-3, but still having this error.
    "Brio intelligence "-Respository tables does't exist,please contact system administartor.

    Thanks

  2. #2
    Join Date
    Nov 2000
    Posts
    224
    It looks like ODBC connection to Oracle database is failing.

    On client machine, can you try opening a command prompt and use

    cmd> tnsping [tnsnames.ora entry]

    Post the result of tnsping.

  3. #3
    Join Date
    Oct 2005
    Posts
    90
    Used TNSNAMES adapter to resolve the alias
    Attempting to contact (DESCRIPTION = (SDU = 32768) (enable = broken) (LOAD_BALANCE = yes) (ADDRESS = (PROTOCOL = TCP)(HOST = xxxx.xxxx.xx.com)(PORT = 1525)) (ADDRESS = (PROTOCOL = TCP)(HOST = xx
    0xx.xxx.xx.com)(PORT = 1525)) (CONNECT_DATA = (SERVICE_NAME = xxxx)))

  4. #4
    Join Date
    Nov 2000
    Posts
    224
    This is not a complete output of tnsping. Generally it will come back with "OK" or some error message.

  5. #5
    Join Date
    Oct 2005
    Posts
    90
    sorry miss that part but tnsping came back with no errors.

  6. #6
    Join Date
    Jan 2001
    Posts
    2,828
    Hi

    When you configure the Oracle ODBC connection there is button to test the connection after you have filled in the various values on the form.

    When you click test connection do you get any errors

    You have a DBA at your place ?

    regards
    Hrishy

  7. #7
    Join Date
    Oct 2005
    Posts
    90
    connection is successfull there are no errors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width