Automatic Memory Management for ASM instance
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Automatic Memory Management for ASM instance

  1. #1
    Join Date
    Jul 2003
    Posts
    131

    Question Automatic Memory Management for ASM instance

    Environment: Windows 2003, Oracle 10gR2, 2 node RAC with ASM and multiple databases

    Is setting Automatic Memory Management (by setting parameter SGA_TARGET greater than zero) for ASM instance a good thing or not.

    Do we have lot of overhead in using Automatic Memory Management, especially for instances that have a low amount of memory allocated. Does Oracle spend more time moving memory allocations back and forth between the pools than doing any real work.

    We have about 20 databases running on RAC for that ASM instance.

  2. #2
    Join Date
    Jan 2001
    Posts
    2,828
    Hi

    If i remember correctly the default setting for ASM instance is Automatic Memory Management unlesss you change it.

    In my previous project i think it was Automatic for al 30+ ASM instances which i know of (unless i have a horrible memory and it has faded in last one month of my bench period :-D)

    regards
    Hrishy

  3. #3
    Join Date
    Jul 2003
    Posts
    131
    Quote Originally Posted by hrishy
    If i remember correctly the default setting for ASM instance is Automatic Memory Management unlesss you change it.
    Hrishy
    Thanks Hrishy.

    But then question is why am I getting this ORA-04031

    Thats what I think is the case. But I don't even have the parameter 'SGA_TARGET' set when I look for its value.

    I tried to alter sga_max_size to increase share_pool_size, I get error.

    SQL> alter system set sga_max_size=140M;
    alter system set sga_max_size=140M
    *
    ERROR at line 1:
    ORA-02095: specified initialization parameter cannot be modified


    SQL> alter system set shared_pool_size=80M scope=both;
    alter system set shared_pool_size=80M scope=both
    *
    ERROR at line 1:

    ORA-32001: write to SPFILE requested but no SPFILE specified at startup


    I do have spfile created when I created ASM instance. I tried to change sga_max_size and shared_pool_size in paramater file, the ASM instance won't even start.

    SQL> show sga

    Total System Global Area 92274688 bytes
    Fixed Size 1289076 bytes
    Variable Size 65819788 bytes
    ASM Cache 25165824 bytes
    SQL> sho parameter shared

    NAME TYPE VALUE
    ------------------------------------ ----------- ----------
    hi_shared_memory_address integer 0
    max_shared_servers integer
    shared_memory_address integer 0
    shared_pool_reserved_size big integer 2516582
    shared_pool_size big integer 48M
    shared_server_sessions integer
    shared_servers integer 0
    SQL> sho parameter target

    NAME TYPE VALUE
    ------------------------------------ ----------- ----------
    archive_lag_target integer 0
    db_flashback_retention_target integer 1440
    fast_start_io_target integer 0
    fast_start_mttr_target integer 0
    pga_aggregate_target big integer 18035507
    sga_target big integer 0
    SQL> sho parameter max

    NAME TYPE VALUE
    ------------------------------------ ----------- ----------
    java_max_sessionspace_size integer 0
    license_max_sessions integer 0
    license_max_users integer 0
    log_archive_max_processes integer 2
    logmnr_max_persistent_sessions integer 1
    max_commit_propagation_delay integer 0
    max_dispatchers integer
    max_dump_file_size string UNLIMITED
    max_enabled_roles integer 150
    max_shared_servers integer
    object_cache_max_size_percent integer 10

    NAME TYPE VALUE
    ------------------------------------ ----------- ----------
    parallel_max_servers integer 0
    session_max_open_files integer 10
    sga_max_size big integer 88M
    SQL>

  4. #4
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    you cannot increase sga_max_size and pretend it can allocate memory just like that

    look oracle parameter references and see a detailed explanation

  5. #5
    Join Date
    Mar 2007
    Location
    Ft. Lauderdale, FL
    Posts
    3,554
    Support Pando; just replace "pretend" with "expect" and all of it will make sense.
    Pablo (Paul) Berzukov

    Author of Understanding Database Administration available at amazon and other bookstores.

    Disclaimer: Advice is provided to the best of my knowledge but no implicit or explicit warranties are provided. Since the advisor explicitly encourages testing any and all suggestions on a test non-production environment advisor should not held liable or responsible for any actions taken based on the given advice.

  6. #6
    Join Date
    Dec 2002
    Location
    Bangalore ( India )
    Posts
    2,434
    well but thats how Pando's lingo is.. :-)
    funky...

    "I Dont Want To Follow A Path, I would Rather Go Where There Is No Path And Leave A Trail."

    "Ego is the worst thing many have, try to overcome it & you will be the best, if not good, person on this earth"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width