db links not working
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: db links not working

  1. #1
    Join Date
    Jan 2001
    Posts
    66

    Question

    i am fairly new to db administration and need some help. I am trying to create a db link to a new development box and receive the following:

    ORA-02085: database link DBDEV.WORLD connects to BDOP.WORLD

    BDOP = production SID and where I am trying to create the link

    DBDEV = new development SID that I am trying to create a link to

    Some db links were created before my involvement to TEST db on seperate box and are successful.

    Steps that I have taken:
    (1) Made sure that the link name is after the db that I attempt to connect to.
    (2) Tried setting 'global_names = false' but received the same error.
    (3) Tried creating a link from DBDEV to BDOP but received:
    ORA-12154: TNS could not resolve service name
    Although I have assured that each db's tnsnames.ora file is updated.

    I am obviously missing something and I am not sure what. Is ther a config file that I did not update or another parameter that I need to modify? Any help would be appreciated.

    Tom

  2. #2
    Join Date
    Oct 2000
    Location
    Cambridge, MA (Boston)
    Posts
    144
    dear thomgreen,

    post your SQL to create the db link. that might help us help you.

    d.

  3. #3
    The GLOBAL_NAME parameter was changed on the target DB?
    Ramon Caballero, DBA, rcaballe@yahoo.com

  4. #4
    Join Date
    Jan 2001
    Posts
    66
    The SQL code is:
    CREATE PUBLIC DATABASE LINK DBDEV.WORLD@BDOPS
    CONNECT TO BDOPS IDENTIFIED BY *
    USING 'DBDEV'

    I changed 'global_names = false' on the source db.

    Thanks for your help.

  5. #5
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    I think there is a restriction that your db_link name should be same as the SID name.
    Also I think there is a restriction on the size of the SID name...can't be more than 4 characters; what is DBDEV (5 characters ?)

    What version of ORacle are you using ?

    - Rajeev

  6. #6
    Join Date
    Jan 2001
    Posts
    66
    Thanks for the help but I figured out the problem. I created DBDEV by transferring datafiles from BDOP and doing a BACKUP CONTROLFILE TO TRACE. Copied over the init.ora, etc... The step that I missed was issuing the following command on new db:
    alter database rename global_name to DBDEV.WORLD;

    Everything is working now.

    Thanks for the input.

    Tom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width