Urgent:Restarting dead background process QMN0 (in production)
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Urgent:Restarting dead background process QMN0 (in production)

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Posts
    231

    Urgent:Restarting dead background process QMN0 (in production)

    I have restarted my production database specifying standbydb archive dest path.It throws backgroung process qmno.So shutdown prodution and also shutdowned standby.then started with without specifying standby archive dest. It shows following error.

    user_dump_dest = /mnt/db/oracle/admin/ISPRO20/udump
    core_dump_dest = /mnt/db/oracle/admin/ISPRO20/cdump
    sort_area_size = 524288
    db_name = ISPRO20
    open_cursors = 300
    star_transformation_enabled= FALSE
    query_rewrite_enabled = FALSE
    pga_aggregate_target = 209715200
    aq_tm_processes = 1
    PMON started with pid=2
    DBW0 started with pid=3
    LGWR started with pid=4
    CKPT started with pid=5
    SMON started with pid=6
    RECO started with pid=7
    CJQ0 started with pid=8
    Wed Mar 14 00:02:14 2007
    starting up 1 shared server(s) ...
    QMN0 started with pid=9
    Wed Mar 14 00:02:14 2007
    starting up 1 dispatcher(s) for network address '(ADDRESS=(PARTIAL=YES)(PROTOCOL=TCP))'...
    ARCH: STARTING ARCH PROCESSES
    ARC0 started with pid=12
    ARC0: Archival started
    Wed Mar 14 00:02:14 2007
    ARCH: STARTING ARCH PROCESSES COMPLETE
    Wed Mar 14 00:02:14 2007
    ARC0: Thread not mounted
    ARC1 started with pid=13
    ARC1: Archival started
    ARC1: Thread not mounted
    Wed Mar 14 00:02:14 2007
    ALTER DATABASE MOUNT
    Wed Mar 14 00:02:19 2007
    Successful mount of redo thread 1, with mount id 3304413702.
    Wed Mar 14 00:02:19 2007
    Database mounted in Exclusive Mode.
    Completed: ALTER DATABASE MOUNT
    Wed Mar 14 00:02:52 2007
    ALTER SYSTEM SET log_archive_dest_state_2='RESET' SCOPE=MEMORY;
    Wed Mar 14 00:03:04 2007
    alter database archivelog
    Wed Mar 14 00:03:04 2007
    Completed: alter database archivelog
    Wed Mar 14 00:03:14 2007


    Restarting dead background process QMN0
    QMN0 started with pid=9



    Wed Mar 14 00:03:16 2007
    alter database open
    Wed Mar 14 00:03:17 2007
    Beginning crash recovery of 1 threads
    Wed Mar 14 00:03:17 2007
    Started first pass scan
    Wed Mar 14 00:03:17 2007
    Completed first pass scan
    4 redo blocks read, 0 data blocks need recovery
    Wed Mar 14 00:03:17 2007
    Started recovery at
    Thread 1: logseq 14263, block 9133, scn 0.926618220
    Recovery of Online Redo Log: Thread 1 Group 1 Seq 14263 Reading mem 0
    Mem# 0 errs 0: /mnt/db/oracle/oradata/ISPRO20/redo01.log
    Wed Mar 14 00:03:17 2007
    Completed redo application
    Wed Mar 14 00:03:17 2007
    Ended recovery at
    Thread 1: logseq 14263, block 9137, scn 0.926638233
    0 data blocks read, 0 data blocks written, 4 redo blocks read
    Crash recovery completed successfully
    Wed Mar 14 00:03:18 2007
    LGWR: Primary database is in CLUSTER CONSISTENT mode
    Thread 1 advanced to log sequence 14264
    Thread 1 opened at log sequence 14264
    Current log# 2 seq# 14264 mem# 0: /mnt/db/oracle/oradata/ISPRO20/redo02.log
    Successful open of redo thread 1.
    Wed Mar 14 00:03:20 2007
    ARC0: Evaluating archive log 1 thread 1 sequence 14263
    ARC0: Beginning to archive log 1 thread 1 sequence 14263
    Creating archive destination LOG_ARCHIVE_DEST_1: '/mnt/backup/arch/ISPRO20/-1063755125_1_14263.arc'
    Wed Mar 14 00:03:20 2007
    SMON: enabling cache recovery
    Wed Mar 14 00:03:20 2007
    Undo Segment 1 Onlined
    Undo Segment 2 Onlined
    Undo Segment 3 Onlined
    Undo Segment 4 Onlined
    Undo Segment 5 Onlined
    Undo Segment 11 Onlined
    Undo Segment 12 Onlined
    Undo Segment 13 Onlined
    Undo Segment 14 Onlined
    Undo Segment 15 Onlined
    Successfully onlined Undo Tablespace 14.
    Wed Mar 14 00:03:20 2007
    SMON: enabling tx recovery
    Wed Mar 14 00:03:20 2007
    Database Characterset is WE8ISO8859P1
    replication_dependency_tracking turned off (no async multimaster replication found)
    Completed: alter database open
    Wed Mar 14 00:03:21 2007
    ARC0: Completed archiving log 1 thread 1 sequence 14263


    please help ....

  2. #2
    Join Date
    Jul 2002
    Location
    Northampton, England
    Posts
    612
    Are you using Advanced Queuing?
    Assistance is Futile...

  3. #3
    Join Date
    Jan 2007
    Posts
    231
    No we are not using Advanced Queuing?
    I have restarted and disabled standby dest. Archive_log_dest_2=rest,min_suceed set to 1. Now it is working properly.

    But i want to know the root cause.
    Trace file at the time of err.

    *** SESSION ID:(3.1) 2007-03-13 22:39:34.309
    *** 2007-03-13 22:39:34.309 42161 kcrr.c
    Initializing NetServer for dest=ISPRO20.STANDBY1
    Initializing PGA storage for Netserver communication
    Allocating a brand new NetServer
    Allocated NetServer 0
    Starting NetServer
    NetServer 0 has been started.Subscribing to KSR Channel 0
    success!
    Indicating recv buffer for KSR Channel 0
    success
    Waiting for Netserver 0 to initialize itself
    Waiting for Netserver 0 to initialize itself
    Waiting for Netserver 0 to initialize itself
    *** 2007-03-13 22:39:38.346 42446 kcrr.c
    Netserver 0 has been initialized
    LGWR performing a channel reset to ignore previous responses
    LGWR connecting as publisher to KSR Channel 0
    LGWR-NS 0 initialized for destination=ISPRO20.STANDBY1
    *** 2007-03-13 22:39:38.346 42894 kcrr.c
    Making upiahm request to NetServer 0
    Waiting for NetServer to respond to upiahm
    *** 2007-03-13 22:39:38.594 43080 kcrr.c
    upiahm connect done status is 0
    Receiving message from NetServer 0
    Destination LOG_ARCHIVE_DEST_2 is in CLUSTER CONSISTENT mode
    Destination LOG_ARCHIVE_DEST_2 is in MAXIMUM AVAILABILITY mode
    Receiving message from NetServer 0
    *** 2007-03-13 22:39:38.630 44311 kcrr.c
    Making upinbls request to NetServer 0
    NetServer pid:16247
    *** 2007-03-13 22:39:38.630 44448 kcrr.c
    upinbls done status is 0
    LGWR: Waiting to hear from Network Server 0
    LGWR: Waiting to hear from Network Server 0
    LGWR: Waiting to hear from Network Server 0
    LGWR: Waiting to hear from Network Server 0
    LGWR: Waiting to hear from Network Server 0
    LGWR: Waiting to hear from Network Server 0
    LGWR: Waiting to hear from Network Server 0

    can any one say root cause.
    pls help.

  4. #4
    Join Date
    Jul 2002
    Location
    Northampton, England
    Posts
    612
    The process you highlighted in your previous post is used to manage AQs. If you don't use them, set AQ_TM_PROCESSES to zero and you should be all sorted.
    Assistance is Futile...

  5. #5
    Join Date
    Jan 2007
    Posts
    231
    ok,I will try by changing advanced queuing process to zero.
    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width