how can I change the max_rollback_segments to UNLIMITED
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: how can I change the max_rollback_segments to UNLIMITED

  1. #1
    Join Date
    Jan 2001
    Posts
    1

    Red face

    I checked the Instance Manager and found the max_rollback_segments were used out(used 26 of 26),
    enqueue_locks and processes are also nearly used out
    (both used 12 of 17). What can I do to it?

    best regards

  2. #2
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    Your questions are somewhat confusing.

    1.) max_rollback_segments
    This parameters limits the number of rollback segments that can be online simultaneously. You said you have 26 of 26 "used" - this means that you have 26 rollback segments online which is also the above limit for your instance currently. Nothing wrong with this. I f you realy need more rollback segments online then you must restart the instance with a higher value for this parameter.

    2.) processes
    "used 12 of 17". If this means that you have set the processes to 17 and you currently have 12 processes, than something is wrong with the whole setup of your database (or maybe I'm missing something). First of all if your process parameter is realy set to 17 then you definitelly don't need 26 rollback segments!! Or do you maybe have multithreaded server configuration? For non MTS configuration 17 is far to low value (at least 5 processes are reserved for background processees, depending on the version and configuration you are using the number of background processes can be even much higher), as it will not allow you to have more than about 10 concurent sessions opened.

    3.) enque_locks
    AFAIK there is no such parameter. Maybe you mean enque_resources. Anyway I don't thing you nid to worry about such an "obscure" parameter unless you are totaly sure this is causing major problems. I think there are far more important parameters that you have to "tune". If your "processes" and "sessons" parameter are sufficiently high you better leave this parameter out of your init file, so that it takes the default value, which is derrived from sessions.

    HTH,
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width