rman: cannot delete device type
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: rman: cannot delete device type

  1. #1
    Join Date
    Jan 2007
    Location
    Berlin, Germany
    Posts
    4

    rman: cannot delete device type

    Hi,

    I configured a defalut device type "sbt_tape" with RMAN, "show all" says:

    CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' PARMS '???nsr_env=(nsr_server=su10, nsr_group=default)';

    Maybe the "???" is the problem, but I cannnot delete the device:
    RMAN> CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' CLEAR;

    old RMAN configuration parameters:
    CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' PARMS '???nsr_env=(nsr_server=su10, nsr_group=default)';
    old RMAN configuration parameters are successfully deleted

    but "show all" says:
    CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' PARMS '???nsr_env=(nsr_server=su10, nsr_group=default)';

    Reconfigure of DEVICE TYPE 'SBT_TAPE' works, but than "show all" says:
    RMAN-12010: automatic channel allocation initialization failed
    RMAN-12014: multiple records for default channel configuration for SBT_TAPE found in catalog

    Any ideas?

    Thanks,
    Last edited by krempe; 01-22-2007 at 10:20 AM.

  2. #2
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    This should go.
    Code:
    configure channel c1 device type sbt parms 'ENV=(NSR_SERVER=, NSR_CLIENT=,NSR_GROUP=)';
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  3. #3
    Join Date
    Jan 2007
    Location
    Berlin, Germany
    Posts
    4
    trying this I get:

    MAN-00558: error encountered while parsing input commands
    RMAN-01005: syntax error: found "identifier": expecting one of: "device, integer"
    RMAN-01008: the bad identifier was: c1

  4. #4
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    try

    configure channel 1 device type sbt parms 'ENV=(NSR_SERVER=nsr_sever_name, NSR_CLIENT=client_name,NSR_GROUP=DEFAULT)';
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  5. #5
    Join Date
    Jan 2007
    Location
    Berlin, Germany
    Posts
    4
    Works!
    But I don't know why I can't get rid of the " configure channel c1 ..."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width