SQL*Plus configuration
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 9 of 9

Thread: SQL*Plus configuration

  1. #1
    Join Date
    Dec 2000
    Posts
    22
    Hello friends!

    Happy New Year first of all!
    I bumped into a problem after installing Oracle8.1.6i on my machine - everything looks fine, but when I connect to my db with SQL*Plus, and execute a command, all system and error messages appear as rubbish. I seems like a problme with the charset or font configuration but I have no idea how to solve it. My system is Win NT 4.0/ English(US) Default.

    Thank you very much for your messages.


  2. #2
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    what kind of error message?

  3. #3
    Join Date
    Dec 2000
    Posts
    22
    Hi.

    Well, all system and error messages appear as rubbish - for example, I enter SLECT * FROM table1;

    Error message that is returned by database is unreadable -
    asdkfjklasd@$%$%%34 %!@$%1234 or smth like that. I guess it is a charset problem, but how to solve it ?

    Please, give me some hints.

  4. #4
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    CHECK NLS_LANG in REGSITRY

  5. #5
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Go to DOS command prompt and log in to svrmgr with connect internal and type 'show parameter nls' and see what NLS_PARM options you have choosen for your database...

    Check NLS_LANG parameter in the registry under /HKEY_LOCALMACHINE/SOFTWARE/ORACLE. It should be 'AMERICAN_AMERICA.WE8ISO8859P1'




  6. #6
    Join Date
    Dec 2000
    Posts
    22
    Do you mean system registry or oracle properties?

    I've looked for NLS settings using regedit
    HKEY_LOCAL_MACHINE -> SYSTEM -> ControlSet...
    but i couldn't figure out what registry entry to change.



  7. #7
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    we mean windows registry and under the entry sreddy suggested, if there isnt one add it manually.

  8. #8
    Join Date
    Dec 2000
    Posts
    22
    Thank you very much, I will try your suggestions.

  9. #9
    Join Date
    Dec 2000
    Posts
    22
    Thanks Friends!
    You suggestion is perfect, it solved the problem.

    Have a nice holiday!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width