SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]

  1. #1
    Join Date
    Oct 2006

    SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]

    I have logged in as Oracle Operating system user and started data loading for
    one database user using SQLLDR, data is loading without any problem.

    I logged in as other(sup_load) Operating system user and I tried to load data
    using SQLLDR for the same(sup) database user. I am getting the error

    " SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]"

    $ whoami

    $ pwd

    $ export ORACLE_HOME=/u111/app/oracle/product/10.2
    $ export ORACLE_SID=migsso

    $ ls -ltr
    total 96
    -rw-rw-r-- 1 sup_load users 163 Nov 28 07:33 aubCO3A2006.A
    -rw-rw-r-- 1 sup_load users 1795 Nov 28 07:35 pir_seca.ctl
    -rw-rw-r-- 1 sup_load users 192 Nov 28 07:37 aubCO3A2006.log

    $ $ORACLE_HOME/bin/sqlldr sup/sup control=pir_seca.ctl bad=aubCO3A2006.bad
    log=aubCO3A2006.log data=aubCO3A2006.A

    SQL*Loader: Release - Production on Tue Nov 28 07:37:56 2006

    Copyright (c) 1982, 2005, Oracle. All rights reserved.

    SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]

    We checked as user permission and and environment variables, we checked for
    Oracle user, and tested in the $ORACLE_HOME/bin directory itself still we are
    getting the same error.

  2. #2
    Join Date
    Nov 2006
    OCIEnvCreate returns -1 what means it failed. As I see the function is related with the connnection establishing and fails most often because of:
    1) lack of priviledges on some OCI shared libaries
    2) Lack of PATH to the shared libraries (check LD_LIBRARY_PATH and PATH)
    3) Messed up tnsnames.ora

    I hope that's a hint. Just google and search metalink and otn for OCIEnvCreate problems

  3. #3
    Join Date
    Oct 2006
    We have added the following environment variable in the user's dot profile as
    well as in the dollar prompt.

    ORACLE_HOME=/u111/app/oracle/product/10.2; export ORACLE_HOME
    ORACLE_SID=migsso; export ORACLE_SID
    export SHLIB_PATH=$ORACLE_HOME/lib32

    The Readonly and execute permission assinged for the directory u111 and its
    subsequent subdirectories ( the Oracle Home which is installed under u111).

    Still we are facing problem O/S user SUP_LOAD. There is no problem with ORACLE
    O/S user. For SUP_LOAD user, It is reading SQLLDR file, but it is not loading
    the data file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width