I have logged in as Oracle Operating system user and started data loading for
one database user using SQLLDR, data is loading without any problem.

I logged in as other(sup_load) Operating system user and I tried to load data
using SQLLDR for the same(sup) database user. I am getting the error

" SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]"

$ whoami

$ pwd

$ export ORACLE_HOME=/u111/app/oracle/product/10.2
$ export ORACLE_SID=migsso

$ ls -ltr
total 96
-rw-rw-r-- 1 sup_load users 163 Nov 28 07:33 aubCO3A2006.A
-rw-rw-r-- 1 sup_load users 1795 Nov 28 07:35 pir_seca.ctl
-rw-rw-r-- 1 sup_load users 192 Nov 28 07:37 aubCO3A2006.log

$ $ORACLE_HOME/bin/sqlldr sup/sup control=pir_seca.ctl bad=aubCO3A2006.bad
log=aubCO3A2006.log data=aubCO3A2006.A

SQL*Loader: Release - Production on Tue Nov 28 07:37:56 2006

Copyright (c) 1982, 2005, Oracle. All rights reserved.

SQL*Loader-704: Internal error: ulconnect: OCIEnvCreate [-1]

We checked as user permission and and environment variables, we checked for
Oracle user, and tested in the $ORACLE_HOME/bin directory itself still we are
getting the same error.