Hi All,

I am facing a wierd issue. When I am trying to connect to oracle through SQLPlus from my laptop, I receive a ORA-12541: TNS:no listener error. The wierd thing is I could connect oracle thorugh Toad and its working fine. Also other applications(Siebel) are able to find tnsnames.ora and connect to the database.

I have installed and uninstalled Oracle multiple times and i recieve the same error. I am using the same tnsnames.ora thats used by my other team mates, which is working fine for them.

TNSPING also gives me the same error.

I used tracing to see the problem.

The following are the trace file snapshot.
NOV-2006 10:46:28:923] nttbnd2addr: entry
[07-NOV-2006 10:46:28:923] nttgetport: entry
[07-NOV-2006 10:46:28:923] nttgetport: port resolved to 1522
[07-NOV-2006 10:46:28:923] nttgetport: exit
[07-NOV-2006 10:46:28:923] nttbnd2addr: looking up IP addr for host: dmnsiebel.tdmn.belo.com
[07-NOV-2006 10:46:28:933] nttbnd2addr: exit
[07-NOV-2006 10:46:28:933] nsmal: 492 bytes at 0xd73ad0
[07-NOV-2006 10:46:28:933] nsmal: 2348 bytes at 0xd73cc8
[07-NOV-2006 10:46:28:933] nsopen: opening transport...
[07-NOV-2006 10:46:28:933] nttcon: entry
[07-NOV-2006 10:46:28:933] nttcon: toc = 1
[07-NOV-2006 10:46:28:933] nttcnp: entry
[07-NOV-2006 10:46:28:933] ntvlin: entry
[07-NOV-2006 10:46:28:933] ntvllt: entry
[07-NOV-2006 10:46:28:933] ntvllt: tcp.validnode_checking not turned on
[07-NOV-2006 10:46:28:933] ntvllt: exit
[07-NOV-2006 10:46:28:933] ntvlin: exit
[07-NOV-2006 10:46:28:933] nttcnp: Validnode Table IN use; err 0x0
[07-NOV-2006 10:46:28:933] nttcnp: exit
[07-NOV-2006 10:46:28:933] nttcni: entry
[07-NOV-2006 10:46:28:933] nttcni: trying to connect to socket 1860.
[07-NOV-2006 10:46:29:053] ntt2err: entry
[07-NOV-2006 10:46:29:053] ntt2err: soc 1860 error - operation=1, ntresnt[0]=511, ntresnt[1]=61, ntresnt[2]=0
[07-NOV-2006 10:46:29:053] ntt2err: exit
[07-NOV-2006 10:46:29:053] nttcni: exit
[07-NOV-2006 10:46:29:053] nttcon: exit
[07-NOV-2006 10:46:29:053] nserror: nsres: id=0, op=65, ns=12541, ns2=12560; nt[0]=511, nt[1]=61, nt[2]=0; ora[0]=0, ora[1]=0, ora[2]=0
[07-NOV-2006 10:46:29:053] nsopen: unable to open transport
[07-NOV-2006 10:46:29:053] nsmfr: 2348 bytes at 0xd73cc8
[07-NOV-2006 10:46:29:053] nsmfr: 492 bytes at 0xd73ad0
[07-NOV-2006 10:46:29:053] nladget: entry
[07-NOV-2006 10:46:29:053] nladget: exit
[07-NOV-2006 10:46:29:053] nsmfr: 164 bytes at 0xd65ef0
[07-NOV-2006 10:46:29:053] nladtrm: entry
[07-NOV-2006 10:46:29:053] nladtrm: exit
[07-NOV-2006 10:46:29:053] nioqper: error from nscall
[07-NOV-2006 10:46:29:053] nioqper: nr err code: 0
[07-NOV-2006 10:46:29:053] nioqper: ns main err code: 12541
[07-NOV-2006 10:46:29:053] nioqper: ns (2) err code: 12560
[07-NOV-2006 10:46:29:053] nioqper: nt main err code: 511
[07-NOV-2006 10:46:29:053] nioqper: nt (2) err code: 61
[07-NOV-2006 10:46:29:053] nioqper: nt OS err code: 0
[07-NOV-2006 10:46:29:053] niomapnserror: entry
[07-NOV-2006 10:46:29:063] niqme: entry
[07-NOV-2006 10:46:29:063] niqme: reporting NS-12541 error as ORA-12541
[07-NOV-2006 10:46:29:063] niqme: exit
[07-NOV-2006 10:46:29:063] niomapnserror: returning error 12541
[07-NOV-2006 10:46:29:063] niomapnserror: exit
[07-NOV-2006 10:46:29:063] niotns: Couldn't connect, returning 12541
[07-NOV-2006 10:46:29:113] niotns: exit
[07-NOV-2006 10:46:29:113] nigtrm: Count in the NI global area is now 0
[07-NOV-2006 10:46:29:113] nrigbd: entry
[07-NOV-2006 10:46:29:113] nrigbd: exit
[07-NOV-2006 10:46:29:113] nigtrm: Count in the NL global area is now 0

Can anybody help as I am with this problem for almost a week now.

Thanks in advance for your respone.